Support » Plugin: Page scroll to id » Scroll Animation not working

  • Resolved haim6130

    (@haim6130)


    Hi!

    First – Thanks for your amazing plugin!

    My problem:
    Usually when I use your plugin in websites, the scroll animation between anchors works great. but when I start using your plugin in my website, the scroll animation doesn’t work and the scrolling looks bad.

    I’d love if you could help me solve this please:
    http://artliner.co.il/

    Another question please:
    How can I remove the # tags in the end of the URL?
    In the plugin settings I already unmarked “Append the clicked link’s hash value (e.g. #id) to browser’s URL/address bar”.

    Thanks a lot!

    • This topic was modified 1 year, 1 month ago by  haim6130.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author malihu

    (@malihu)

    Hello,

    Check the solution below from a similar request (see steps 2 and 3):

    https://wordpress.org/support/topic/scroll-effects-conflicts-with-elementor-scrolling/#post-10602774

    You can see the full thread here.

    Let me know if this helps

    Hi,

    Thanks for you reply!

    Unfortunately it didn’t worked for me.
    I’ve unchecked the “Prevent other scripts from handling plugin’s links” option and tried the 2 scripts one after another below the “<?php wp_footer(); ?>”, but it didn’t fix the animation.

    What else can I do?

    Thanks!

    • This reply was modified 1 year, 1 month ago by  haim6130.

    Hi,

    I found the solution, It’s my mistake.
    I didn’t use your plugin anchors, and the animation didn’t work.
    When I created anchors with your plugin widget, the animation start working perfectly.

    Thanks a lot!

    Plugin Author malihu

    (@malihu)

    It seems to work for me, meaning page scrolling happens because of “Page scroll to id” (no other script scrolls the page).

    The hash (#) you see in the end of the URL comes from another script (maybe from jet-scroll-navigation). Is this another plugin? Have you installed other plugins that handle page scrolling (e.g. the one that creates the aside bullets)? Maybe there’s an option there to stop changing the URL hash while scrolling?

    When you say “scrolling looks bad” do you mean scrolling performance (i.e. the animation looks choppy)? If yes, this probably has to do with the other script/plugin that changes the hash (#) in the end of the URL. This is because it does this on-the-fly while the page is animating. Keep in mind that this other script changes the hash even if you scroll with the mousewheel or by manually dragging browser’s scrollbar.

    Of course, choppy animations may have other reasons like the type of content, what other scripts are running etc. but my guess is that if you somehow disable the hash changing while scrolling, the animation will be much better.

    In addition, changing the URL hash on-the-fly while the page is scrolling (like you have it now), creates other problems as well like messing the user’s browsing history (e.g. the user has to click browser’s back button many, many times to actually go back or leave your page). This is never good for the user experience.

    Hope this helps

    Hi!

    About the animation – now it works great on the desktop, but in the mobile the page “jumps” to the anchor withput any animation at all… it’s the exact same menu. you could check it by minimizing the browser untll the menu becomes humbrger icon.

    About the url tags – you were right! I disabled the other plugin and now it’s okay.

    Thanks a lot malihu!

    Plugin Author malihu

    (@malihu)

    It seems that you’ve set to disable the plugin when the viewport is less than 1400 pixels wide. Just go to plugin settings and remove the 1400 value from “Disable plugin below screen size”.

    haim6130

    (@haim6130)

    Genius!

    Thank you very much!

    Plugin Author malihu

    (@malihu)

    You’re welcome 🙂

    Marking this as resolved.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Scroll Animation not working’ is closed to new replies.