Support » Plugin: Page Speed Optimization » Scripts not loading if “Proxy External Scripts”

  • Resolved planningtank

    (@planningtank)


    Hello,
    If “Proxy External Scripts” is enabled under java script optimization than many of the features stops working like jetpack related post, any popup plugin, sumo me share feature to name a few. I am using these on http://planningtank.com kindly assist on how this can be solved?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Yes. I’m facing the exact same issue. In my situation my CSS is not loading properly. When I use the Chrome “Inspect” it shows 403 Prohibiden for my CSS and JS links. Following is an example.

    http://www.myblog.com/?url=http://cdn1.myblog.com/wp-content/plugins/social-widget/style.css&type=css&abtf-proxy=47d36f7ff3dc89d1577534540256b835
    
    http://www.myblog.com/?url=http://cdn2.myblog.com/wp-content/plugins/above-the-fold-optimization/public/js/jquery.lazyloadxt.widget.min.js&type=js&abtf-proxy=47d36f7ff3dc89d1577534540256b835
    
    http://www.myblog.com/?url=http://cdn2.myblog.com/wp-includes/js/wp-embed.min.js&type=js&abtf-proxy=47d36f7ff3dc89d1577534540256b835
    • This reply was modified 3 years, 5 months ago by Bluemad.
    • This reply was modified 3 years, 5 months ago by Bluemad.
    Plugin Author Optimalisatie.nl

    (@optimalisatie)

    Dear planningtank,

    Thank you for taking the time to report the problem!

    There is no compatibility issue with the mentioned plugins. In the below example the SumoMe share feature is used with the External Javascript Proxy (see console) and it is working well.

    Above The Fold Optimization and SumoMe Social Share widget

    The problem is caused by the javascript component of the proxy that is causing protocol independent scripts (e.g. src="//www.google-analytics.com/analytics.js" to fail. I am not sure yet why the problem occurs specifically on your website as the problem does not occur on any other website that I tested the plugin on.

    The proxy is now called without http://

    http://planningtank.com/?url=%2F%2Fload.sumome.com%2F&type=js&abtf-proxy=SECRET-KEY

    v2.5.3 solves the problem and makes sure that protocol relative urls are translated before being sent to the proxy. The proxy itself is now also able to handle protocol relative urls.

    Please let me know of v2.5.3. solves the issue.

    [ Signature moderated ]

    @optimalisatie

    Thank you for your prompt response. I tried few modifications from my side and disabling any potential conflicting plugin. I have updated to v2.5.3. and js is loading now. But now I am facing another issue which is of CSS just like @bluemad.
    The CSS works fine with the inbuilt CSS editor of chrome and I used following lines to solve the issue of preventing overlapping content

    #comments.comments-area {
    display: block;
    overflow-y: visible;

    This custom CSS no longer works and some of the content gets slides behind the footer. Content sliding behind footer

    Please check

    Plugin Author Optimalisatie.nl

    (@optimalisatie)

    Hi planningtank!

    The problem you describe appears to be related to invalid or low quality Critical CSS. Did you try the Critical CSS Quality Test?

    The Above The Fold Optimization plugin does not minify or optimize CSS in the frontend. The plugin only (optionally) optimizes the loading and render process of intact CSS and adds the Critical CSS that is configured in the settings.

    [ Signature moderated ]

    • This reply was modified 3 years, 2 months ago by Jan Dembowski.

    Hello,

    Thank you for help. Its a complete mess for me now. Even if I disable all the plugins and return to default comment system I am getting a overlapping issue. I will try installing the theme again. Anyways, your help is appreciated!

    Plugin Author Optimalisatie.nl

    (@optimalisatie)

    Hi planningtank,

    If the problem persists even when all plugins are disabled, it is most likely to be caused by the theme CSS.

    [ Signature moderated ]

    • This reply was modified 3 years, 2 months ago by Jan Dembowski.

    Hello,

    v2.5.3 solves the problem and makes sure that protocol relative urls are translated before being sent to the proxy. The proxy itself is now also able to handle protocol relative urls.

    The scripts loaded by the proxy getting http:// protocol, with the site on https:// gives me an mixed content error.

    Can you give me a hand please.

    Thanks

    Plugin Author Optimalisatie.nl

    (@optimalisatie)

    Hi mmdijkman,

    Thank you for reporting the problem!

    I have not seen that problem before. My first idea that it may be caused by an invalid <base href="" /> tag in the HTML.

    The relative URL conversion takes place using a simple javascript method (an <a> element is created and the href is set). It is not a possible cause.

    [ Signature moderated ]

    • This reply was modified 3 years, 2 months ago by Jan Dembowski.

    Hi PageSpeed.pro,

    Thank you for your reply!

    Can’t find any <base href=”” /> in the HTML

    I double checked all the urls in the database and replaced all http to https

    In my wp-config.php

    if ($_SERVER[‘HTTP_X_FORWARDED_PROTO’] == ‘https’)
    $_SERVER[‘HTTPS’]=’on’;

    https://snag.gy/yVPleI.jpg

    I’ve really no idea what’s going wrong

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Scripts not loading if “Proxy External Scripts”’ is closed to new replies.