Support » Plugin: SMTP Mail » Scripts Loading on Front End

  • Resolved Sean Thompson

    (@seanthompson)


    Hi,

    I found your plugin when the SMTP plugin I was using started having problems. I really like the fact that this is a smaller plugin, and the mail started working again as soon as I installed and configured it.

    There are two problems though.

    1) The test mail/debug doesn’t seem to work. When I send the test mail with or without errors/debug enabled, no mail goes through. (Mail worked fine when I tested my contact form.) When I enable errors/messages There isn’t anything to be found anywhere.

    2) this plugin loads scripts on the front end including jquery/jquery/migrate. The only script that loads on the front end of my site otherwise is on the contact page for the form.

    Enqueued in head…

    <script  data-cfasync="false" src='/wp-includes/js/jquery/jquery.js'></script>
    <script  data-cfasync="false" src='/wp-includes/js/jquery/jquery-migrate.min.js'></script>

    Enqueued in footer…

    <script type='text/javascript'>
    /* <![CDATA[ */
    var smtpmail_setting = {"savedata":"0"};
    /* ]]> */
    </script>
    <script  src='/wp-content/plugins/smtp-mail/media/smtp.js'></script>

    I’m not sure why this is needed on the front end. Can I disable this and have the plugin still work?

    Thanks in advance,
    Sean

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Scripts Loading on Front End’ is closed to new replies.