The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Scriptaculous 404 Errors (6 posts)

  1. nicholasjcoleman
    Posted 6 years ago #

    I'm stumped!

    I'm receiving DOZENS of 404 errors in my logs, all pointing to:


    Site located at http://after.davecrossweddings.com

    Any ideas?

  2. alism
    Posted 6 years ago #

    Have a look at this file:

    Now I'm no Javascript expert or anything, but it looks like this part:

    var includes = s.src.match(/\?.*load=([a-z,]*)/);
          (includes ? includes[1] : 'builder,effects,dragdrop,controls,slider,sound').split(',').each(
           function(include) { Scriptaculous.require(path+include+'.js') });

    ...is looking for those files, which as you say, don't exist. So you've either got some files left to upload, or a bit of unnecessary script. I'd probably go back to whoever created scriptaculous.

  3. nicholasjcoleman
    Posted 6 years ago #

    Since these files are located in the wp-includes folder, I'm guessing that part of WordPress base install uses Scriptaculous code to work... and probably, doesn't use these specific modules, but is loading them anyway... except the base WordPress install doesn't use the files, so they aren't in the folder at all.

    So... that begs the question, why are they being called? Is this intentional?

  4. nicholasjcoleman
    Posted 6 years ago #

    Spoke too soon... I think maybe it's a result of a plugin that's trying to load the Scriptaculous libraries and is doing it from the base WordPress includes...

  5. alism
    Posted 6 years ago #

    Yeah, I think you're probably right there.

    (for some reason I didn't twig above that Scriptaculous was part of WP core - not sure why! Brain is absent today, sorry)

  6. nicholasjcoleman
    Posted 6 years ago #

    Fixed it!

    It's an error in the d13slideshow plugin.

    That plugin calls and loads:
    which is part of WordPress core... for some reason, this loads the scriptaculous effects with a prefix of "wp-".

    I altered the d13slideshow.php file to call:
    which is ALSO part of WordPress core and it now no longer loads the effects files with the (incorrect) "wp-" prefix.

    I've notified the plugin author... problem solved (got rid of THOUSANDS of 404 errors, thankfully).

Topic Closed

This topic has been closed to new replies.

About this Topic