Support » Plugin: WooCommerce Stripe Payment Gateway » screwed up my whole site

  • Resolved purplechin

    (@purplechin)


    added the woocommerce plugin and stripe for woocommerce plugin. I accidentally activated the stripe plugin first and now I get this message instead of access to my site. It doesn’t matter where I g0–homepage, /wp-admin or any page–still the same message.

    How can I get out of this and back into my site to delete the plugins and reinstall them properly? Also, don’t throw a bunch of code at me as I’m not a code monkey. I wish I was, but I’m not.

    Fatal error: Class ‘WC_Payment_Gateway_CC’ not found in /home/fu58uf538xqf/public_html/jrreedauthor.com/wp-content/plugins/woocommerce-gateway-stripe/includes/abstracts/abstract-wc-stripe-payment-gateway.php on line 13

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • The only way to resolve this would be to FTP in to your hosting and delete the woocommerce-gateway-stripe plugin folder, you maybe able to do this through the hosters control panel if they offer a file explorer.

    I can only suspect that the error is due to the fact that woocommerce plugin has not been activated, but I would have assumed the stripe plugin checks that woocommerce is active before it will enable itself.

    Plugin Author royho

    (@royho)

    When you have Stripe active but not WooCommerce, it shouldn’t give you any errors. You should see this message in admin http://cld.wthms.co/e1iITK

    Plugin Support Mike M. a11n

    (@mikedmoore)

    Automattic Happiness Engineer

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘screwed up my whole site’ is closed to new replies.