WordPress.org

Support

Support » Themes and Templates » Screenshot Preview of Themes Not Showing Up

Screenshot Preview of Themes Not Showing Up

  • I’ve installed WordPress successfully in a new site. In the Presentation page of the Admin section, preview screenshots of the default themes show up as expected. However, I FTP’d a dozen or so of the WordPress Themes Contest winners (after unzipping them on my hard drive) and none of these present screenshot previews in Presentation.
    The new themes are in the proper folder (same as the default themes) and are set to 755 in Permissions, as are the default themes.
    Any idea what’s wrong?

Viewing 5 replies - 1 through 5 (of 5 total)
  • WP doesn’t actually generate a preview of the theme, the theme needs to have a screenshot image, screenshot.png I believe, I’ know that format works, but I’m not sure if others do or do not. I’m guessing they are just missing the image for the preview, hence why there is no preview. 🙂

    Cheers,
    Michael.

    Yup, you have to make your own screenshot.pngs for themes that were around prior to 2.0.

    Thanks. I thought this might be the case, but sort of assumed that the contest winners would include the preview PNG. I’ll generate them for the themes I’m likely to be using.

    Back when those folks won the contest, there WAS no screenshot.png needed. Probably never occurred to any of ’em to go back and put one in….

    FWIW, I’ve found several of the contest-winning themes on other WP-oriented websites, with screenshot.jpg files included. Thanks again for the responses.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Screenshot Preview of Themes Not Showing Up’ is closed to new replies.
Skip to toolbar