Support » Plugin: SiteGround Optimizer » “Scrape nonce check failed. Please try again.” When editing functions.php

  • Resolved Samir Rifai

    (@srifaia)


    When saving edits in functions.php file, I get the error: “Scrape nonce check failed. Please try again”. I’ve identified SG Optimizer as the source of the problem. I’ve disabled the plugin, got back to functions to save it with no problem, then activated the plugin again. I have WordPress 5.3.2 and Woocommerce 4.0.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    Sorry for the late reply. I really did a lot of troubleshooting in it but nothing related to the SG Optimizer is causing this. There must be some other plugin interfering with the Optimizer and resulting in the error.

    Thread Starter Samir Rifai

    (@srifaia)

    Hi Hristo,
    I´ve updated SG Optimizer to versión 5.4.6 and Woocomemrce 4.0.1 and the problem is solved. Must have been something in the last version mixed with other updates.
    Thanks for your time.

    Just had the same exact problem.

    It is DEFINITELY the SG Optimizer plugin. I literally had the same problem when trying to update the footer. I found this thread. I literally ONLY deactivated the SG Optimizer plugin and was able to make the change, then reactivated the SG Plugin. Just an FYI, something in the SG plugin is causing a conflict.

    Thread Starter Samir Rifai

    (@srifaia)

    Thanks for your input. I had no problems after the update and still working fine.

    I was facing same issue
    I checked everything and I found that object cache was causing problem. Just disable it you will be able to edit functions.php file

    Thanks, @ranjeetraj198 just followed your tips by displaying object cache and works fine for me

    Hi,
    I also got this error to go away by disabling SG Optimizer plugin version 5.6.5, making my functions.php change, and then re-enabling the Optimizer.

    btw, I had also tried “Purge the SG Cache” in admin before disabling the Optimizer, and no dice.

    So I tend to agree with “yesyeah” above, that there is something amiss relating to the SG Optimizer.

    Cheers, Dave

    I also facing same issue. After deactivate the plugin, I can update the function.php. We disabled all the plugin and activate all the plugin except SG Optimizer. it is only happened once SG Optimazer is activated.

    I can confirm I needed to disable also SG Optimizer to update functions.php from the Theme Editor in the dashboard. I also tried to manage it from Siteground Tools, but it did not solve it. Not very practical.

    @hristo-sg Would be good to indicate this in SG Optimizer documentation and/or let know exactly what setting/feature of the SG Optimizer causes this.

    BEST regards,

    • This reply was modified 1 year, 6 months ago by Miguel.

    @hristo-sg can we expect a fix for this? I have literally +30 websites on SG and having to disable your plugin every time I need to edit such files is really annoying. Thank you!

    Hello,

    I faced with same issue several times. I deactivated all third-party plugins and the problem remains. In my case, one of the plugins caused the problem. Also, I saw that this issue usually hosting-related.

    Good luck.

    I just arrived to this error.
    Im trying to edit function.php and wordpress give me this error:
    “Scrape nonce check failed. Please try again”
    I just install three plugin(elementor,elementor pro,woocammrece) and i dont have SG optimizer!
    What im i gonna do?

    Note : my site is in local server(XXAMP)

    Guys how can i ask question in this forum?
    I cannot find anything to ask my question!!

    hunnsdon

    (@hunnsdon)

    I also had this error. I disabled both SG Optimiser and Wordfence Security, edited the php, reactivated plugins and all is fine, hopefully.

    Bub

    (@jdenning47)

    TNX solved my problem too

Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.