Support » Plugin: Schema & Structured Data for WP & AMP » Schema type QAPage, Question and Answer

  • Resolved Jayanta

    (@jkmwp)


    Hi there,
    Would you please add the schema type qapage, question and answer for the custom post types created by the Q&A plugins like DWQA Question?
    Another question: I’m not using amp on my site. Does this plugin still work on normal sites?
    Thanks and regards,
    Jayanta

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Sanjeev Kumar

    (@sanjeevsetu)

    Hi @jkmwp,

    I would like to inform you that we already have qapage schema type which is compatible with DWQA Questions. Just you need to enable it (https://prnt.sc/m7027w) and add schema type to (https://prnt.sc/m703a1) after that it will automatically generate schema for QA page.

    Yes, It is independent from AMP. It is working on normal site.

    Hope this helps you.

    Thanks,
    Sanjeev

    A very big thanks for the prompt reply.
    I have installed and configured the plugin.
    My long search for a perfect no-bloat schema markup plugin for my specific need comes to an end now.

    Only one problem when I tested with the Google structured data testing tool:
    “The attribute logo.height has an invalid value.” error is showing in schema type “Article”. Any suggestion on this?
    Thanks again,
    Jayanta

    Plugin Support Sanjeev Kumar

    (@sanjeevsetu)

    Inside schema settings there is a tab knowledge graph please add logo there with 160*50 or your website logo size should be 160*50. It will solve your problem.

    Thank you so much.

    Solved. Thanks a lot.

    Doesn’t appear to be working. Installed this plugin, installed DW QA, enabled it per screenshot #1, and then created a new schema for QAPage per screenshot #2.
    Nothing shows up in source for QAPage.

    I tried enabling it forcefully within the Edit page area; despite having blank fields for the “Question Title” , etc.
    Nothing.

    Confirmed saswp_post_specific_schema_output was called by post specific override.
    Disabled it.
    Stepped into the saswp_schema_output()
    –> $Conditionals is false on the actual questions posts, resulting in immediate plugin exit.
    –> $schema_type is always Article on all other pages, including those using the shortcode for questions (including the automatically created page /dwqa-questions/)
    –> /question/ category page (produced by dwqa) also has no $Conditionals, immediate exit.

    How exactly is this supposed to work? Certainly I’m missing something here..

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.