Support » Plugin: Schema » Schema slows site search

  • With Schema activated searches on our larger sites jumps from 3 seconds to 20 seconds. When I disable Schema, the time drops right back down to 3 seconds.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Note. This is affecting only our production sites, our development/staging sites are not affected. Some differences listed below.

    Production
    Hosted at Rackspace. ( Load Balanced dual Cloud Server )
    Memcached & varnish are installed.
    Behind Sucuri firewall.
    HTTPS/2

    Staging
    Hosted at SiteGround ( VPS )
    No memcached or varnish
    No firewall.
    hhtp basic auth
    HTTP

    Plugin Author Hesham Zebida

    (@hishaman)

    This mostly has nothing to do with your web host.

    The plugin doesn’t output any markup on search archives pages, but maybe several pages gets updated by Schema for the first time when you do the search, which will take a few extra seconds to be done.

    Have you tried repeating the same search query to see if it gets faster?

    Yes. All searches repeated or not take 20 seconds or more to complete while Schema is activated. Deactivate it and they run as normal.

    But it only happens on the one server, not on the other. All of the WP, theme, plugins etc are identical.

    We installed another plugin to test, and it does not slow search, but it also lacks features. We really want comments in the schema JSON and none of the others seem to include those.

    Plugin Author Hesham Zebida

    (@hishaman)

    I see! Thanks for the info.

    But, I was mistaken, I went back to check the code and found out it doesn’t run on search pages as you can see in this line:

    // do not run on front, home page, archive pages, search result pages, and 404 error pages
    if ( is_archive() || is_home() || is_front_page() || is_search() || is_404() ) return;

    It tells the plugin not to run on any of those pages. So, this is strange. I’ve done a quick test and can’t see any additional queries happen in search pages.

    At any how, there must be a reason for that, but I can’t put my hands on it. Do you see any errors? maybe you can check for error logs?

    What PHP runs on the server? (at least 5.4 or higher)

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Schema slows site search’ is closed to new replies.