Support » Plugin: Schema & Structured Data for WP & AMP » Schema output with invalid ImageObjects

  • Resolved billrw3

    (@billrw3)


    In short, the schemas I’m having output include ImageObjects having nested arrays of ImageObjects with index numbers as keys (note that the nested items are sized versions of the images on the post). I have no other schema plugins, and have disabled schema generation on Yoast. The entries below the “0” and “0” entries read as errors in the structured data testing tool.

        "image": {
                    "@type": "ImageObject",
                    "@id": "https:\/\/nerdbot.com\/2020\/08\/20\/the-beastmaster-38-good-bad-reboot\/#primaryimage",
                    "url": "https:\/\/nerdbot.com\/wp-content\/uploads\/2020\/08\/fgbk1yjjc6gm76nqtj6bhlvlfxu.jpg",
                    "width": "1000",
                    "height": "1500",
                    "0": {
                        "@type": "ImageObject",
                        "url": "https:\/\/nerdbot.com\/wp-content\/uploads\/2020\/08\/BQ4.jpg",
                        "width": 800,
                        "height": 533
                    },
                    "1": {
                        "@type": "ImageObject",
                        "url": "https:\/\/nerdbot.com\/wp-content\/uploads\/2020\/08\/Outlaw2.jpg",
                        "width": 620,
                        "height": 458
                    },
Viewing 10 replies - 1 through 10 (of 10 total)
Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Schema output with invalid ImageObjects’ is closed to new replies.