Support » Plugin: Schema App Structured Data » Schema App – Add to Blogposting Deafault Markup not working

  • Resolved tuulaa

    (@tuulaa)


    Issue number 1
    “Add to Blogposting Default Markup” -button not working.
    The session moves to WordPress driven Schema App -application, but there is a message “Sorry, resource to extend wasn’t provided. If you just logged in retry, otherwise use the editor to create new resources”
    and Resource source is empty.

    Issue number 2
    I have to edit all my blogpost, because “The attribute publisher.itemtype has an invalid value.” – Google test saying.
    And I think that all my blogposts contain the wrong person field.
    You have in your database 2 Person filetypes:
    person (http://ontologies.semanticarts.com/gist#person)
    person (http://schema.org/person)

    If my blogposts contain “person (http://ontologies.semanticarts.com/gist#person)”, then there is something wrong between Schema App and WordPress.
    Could you please check.

    I can edit all my posts, if I get to edit them. There is only that error.

    Otherwise your app is awesome! I like it.

Viewing 1 replies (of 1 total)
  • Plugin Author vberkel

    (@vberkel)

    Hi Tuulaa,

    Issue #1, the issue was introduced when we moved schema app over to https. The upcoming version 1.3.2 fixes this.

    Issue #2, this is more a problem with Google’s testing tool. The schema.org vocabulary has https://schema.org/publisher expecting either an Organization or Person. Google’s Testing Tool is validating against the Article Top Stories feature https://developers.google.com/search/docs/data-types/articles#article_types however. So what the testing tool is saying that publishers who are individual People you are not eligible for that feature even though it’s valid schema.org information. If you had a look in Search Console Structured Data report you wouldn’t see any errors with those pages since its valid schema markup.

    You can change the publisher type in Settings –> Schema App by selecting Organization rather than Person. That there are two Person types showing up in the database is a problem of filtering that I need to fix. If prompted, always pick the schema.org/Person.

    Regards,
    Mark

Viewing 1 replies (of 1 total)
  • The topic ‘Schema App – Add to Blogposting Deafault Markup not working’ is closed to new replies.