Support » Fixing WordPress » Scheduling Posts

  • Resolved JennyBHoney

    (@jennybhoney)


    I try to write my posts at night and schedule them to publish the following morning. The last 2 posts I scheduled didn’t publish at all. I had to go in to edit the post and change it to draft, and then hit “Publish.” Is there a way to fix this? I can’t figure out if I did anything that is causing this error.

    http://www.honeyandbirch.com

Viewing 11 replies - 1 through 11 (of 11 total)
  • From my understanding these are controlled by the automatic wp-cron that is called when there is traffic to your website. Did you receive ANY traffic during this time that would have called the wordpress index file?

    My site receives a few hundred visitors every day. Does the traffic need to be at the exact same time the post is scheduled to go live?

    jennybhoney, I personally find that calling wp-cron using a true cron job is far more reliable than depending on wp-cron itself. If you have a caching plugin on your site, you might try disabling it, as that can sometimes create this sort of problem.

    I don’t know whom you host with, but you might wish to contact them to see if they support cron, or simply look in your control panel to see if an option to create cron jobs exists. If your host does not support cron, there are some online services you can use. Some of these are free, but generally allow an insufficient number of cron jobs to be run. Others charge a very small fee, and it’s worth it if you really need reliable cron.

    Please don’t hesitate to get back with us if you need further assistance.

    Thank you abletec, I will see if I can figure it out.

    jennybhoney, all this stuff about cron, etc., can feel a little intimidating, I know. We’ll happily help if it feels like that. I remember when I was just getting started, too, & it wasn’t a fun time. WordPress takes a lot of the headaches out of running a website, but there’s still some technical knowledge required, especially if you want to customize the way it works. Do look to see if there are plugins like wp-cache or wp-totalcache on your site, as sometimes these interfere with scheduling. Also, make certain your server’s timezone is set to your own, as that can create some discrepancies in scheduling, especially if the server timezone is behind yours. You find this in ‘Settings > General’.

    Again, do let us know if we can help you further–that’s why we’re here. It’s just hard to know how much to explain, especially since I have no idea with whom you host, &, as a consequence, I don’t know what their facilities are. But we’re anxious to help you resolve your issues.

    All the best.

    Thanks Abletec – it’s definitely a bit overwhelming. I disabled the cache program I was using, scheduled a test post and still no go. Also, my timezone is correct.

    I found the cron.php file as well as the area to add Cron Jobs in my c-panel (I use bluehost currently.) Do I have to modify the cron.php file to add manual cron jobs? Also, I need to enter a command … I been doing some poking around and found a site that recommends this command:

    */5 * * * * wget -q -O – “http://mydomain.com/wp-cron.php?doing_wp_cron=date +\%s” > /dev/null 2>&1

    I think that means every 5 minutes run wp_cron – do I need to put that all in when Bluehost’s options offer drop down menus of time increments?

    Andre

    (@andrejcarter)

    JennyBHoney – Did you update to WordPress 4.0? I’ve noticed 3 posts missed their scheduled time since updating to 4.0 (2 missed on RCs and 1 missed on real 4.0). I believe all of mine were missed when multiple posts were scheduled at the same time and I believe it’s been the last post created of the group that was missed.

    Andre, I updated to WordPress 4.0 yesterday, but first noticed the problem on 8/29.

    Hi, jennybhoney. You can just use the dropdown menus in your CPanel to set the time. I like setting it to an odd minute, i.e., 09 or 12, so as not to compete w/everyone & his brother, sister, dog, & cat who’s running a cron on the hour.

    Mine looks like:
    path-to-php -f -path-to-wp-cron.php >/dev/null

    I wouldn’t put >/dev/null in there until you’re certain the cron job is running correctly. I schedule this to run at midnight & noon, at 16 minutes past the hour.

    You can find info regarding running cron on Bluehost at:
    https://my.bluehost.com/cgi/help/168

    Keep us apprised, won’t you?

    Thank you so much abletec! That worked and my test post posted as scheduled.

    To think, I was about to hire someone to help me out…

    jennybhoney, 1 thing you might also wish to do is to edit your wp-config.php, & add the following line:
    define( ‘DISABLE_WP_CRON’, true );

    That way, wp-cron will fire when you tell it to & not spuriously.

    Glad we could help, thanks for marking the topic resolved, & don’t hesitate to let us know if we can assist you further.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Scheduling Posts’ is closed to new replies.