WordPress.org

Support

Support » Multisite » Scheduler problem for both posts and back up

Scheduler problem for both posts and back up

  • Hi,
    I upgraded to 3.5 and now my scheduler doesn’t work.
    I’ve had to manually publish posts every single time since the upgrade.

    I also just noticed that my WPB2D back up to dropbox didn’t happen as scheduled. The last back up was on 12/16 prior to the upgrade. The next back up was scheduled for 12/23 and didn’t happen. I just tried running one for today 9 am and didn’t happen either.

    I am running Multisite feature. The main sites right now are:
    jkdunlimited.com and TheMartialMother.com

    Please help. Thank you.

Viewing 15 replies - 1 through 15 (of 58 total)
  • Install http://wordpress.org/extend/plugins/cron-view/ and see if the cron jobs are scheduled?

    Thank you.
    Question 1: Does the plug in only show me the status on the Crons to pinpoint where the problem is? or Does it actually help me fix the problem once found?
    I consider myself advanced consumer level but I am not developer savvy. I don’t even really know what Crons are 🙂

    Question 2: The plugin page states it is compatible up to version 3.3.2
    Is that a problem since I’m running 3.5?

    Thank you. Merry Christmas 🙂

    Q2: Not a problem.

    Q1: It should show you if the jobs are being scheduled. I’m hoping that gives us a place to start.

    What do you think of just reinstalling wordpress?
    After all the problem started after the upgrade… Since scheduling was working before and scheduling does work for most people running WP 3.5, it seems that something is wrong with one of the new files that was downloaded…
    If that’s the case, then deleting the current WP installation (while keeping my wp-content, wp-config, and .htaccess intact) and reinstalling WP may fix the problem?

    Thank you.

    Or maybe at the minimum reupload the wp-cron.php file?

    I’m continuing with my research for the source of the problem and when I look at the cron.php file in
    WP 3.4.2
    line 25 says: if ( $next && $next <= $timestamp + 600 )

    line 209 says: if ( $lock > $local_time + 10*60 )
    line 320 says:
    ‘hourly’ => array( ‘interval’ => 3600, ‘display’ => __(‘Once Hourly’) ),
    ‘twicedaily’ => array( ‘interval’ => 43200, ‘display’ => __(‘Twice Daily’) ),
    ‘daily’ => array( ‘interval’ => 86400, ‘display’ => __(‘Once Daily’) ),

    in WP 3.5,
    line 25: if ( $next && $next <= $timestamp + 10 * MINUTE_IN_SECONDS )

    line 209: if ( $lock > $gmt_time + 10 * MINUTE_IN_SECONDS )

    line 320:

    ‘hourly’ => array( ‘interval’ => HOUR_IN_SECONDS, ‘display’ => __( ‘Once Hourly’ ) ),
    ‘twicedaily’ => array( ‘interval’ => 12 * HOUR_IN_SECONDS, ‘display’ => __( ‘Twice Daily’ ) ),
    ‘daily’ => array( ‘interval’ => DAY_IN_SECONDS, ‘display’ => __( ‘Once Daily’ ) ),

    Also everywhere it says $local_time in WP 3.4.2, it says: $gmt_time in WP 3.5

    Could that be part of the problem for missed schedule? I’m very tempted to just change the cron.php file in WP 3.5 with the one from WP 3.4.2…

    Thank you.

    I am documenting what I did in case it helps someone else.

    I tried uploading the wp-cron.php file as well as the cron-php file (located in wp-includes) from WordPress 3.4.2. That didn’t fix the problem.

    I just replaced WordPress 3.5 with WordPress 3.4.2 and the problem is fixed. So it is obviously something with the 3.5 udpate. Until I hear about what I can do to fix this missed schedule problem, I will not be updating to 3.5.

    Thank you.

    A couple people have reported this error… I’m not sure why.

    This plugin supposedly helps: http://wordpress.org/extend/plugins/wp-missed-schedule/

    I’m having the exact same issue: scheduler worked in 3.42, no longer works in 3.5.

    @ipstenu, while that plugin DOES work, it also queries the database every 5 minutes (be default). this is a lot of overheard for a single scheduled post per day. Also, I have noticed a distinct lag in my site when that plugin is enabled.

    @gilzow, I hear you. I didn’t want to install a plugin for something that should work natively within the WordPress installation.
    It’s always tricky: everyone recommends updating but it’s only normal people resist it… I didn’t have any problems running 3.4.2 and then I update and my posts don’t get published! It wouldn’t be too bad if there was a solution readily available but there is not and I’ve spent hours on this already.

    So until I can actually find a simple fix to the problem (without plugins), I will stick to 3.4.2.

    I’m leaving this post as unresolved in case someone actually knows the solution for missed scheduled posts on WP 3.5.

    gilzow – Do you know how wp-cron works? When someone visits your site, it checks to see if anything needs to run 🙂 So having it manually be forced to run every 5 minutes doesn’t really hurt you, though if you wanted to change it run every hour or x hours… But Yes, it will make your site run slower than how cron works, because it’s … not cronning.

    The problem is that we can’t reproduce this one 🙁 I use scheduled processes on many sites and they work just fine. I presume you’ve both tried turning off plugins and switching to the default theme, to see if it’s something else on your site causing this?

    @ipstenu, actually, yes; I have a very solid understanding of how wp-cron works (which is why I have always wondered why the default time-out in cron.php is set so incredibly low).

    I have NOT tried deactivating all plugins and/or switching to the twentyten theme, yet. This is a production site so neither of those are an option for me. I’ll have to replicate the site to a separate server in order to go into this level of troubleshooting. While certainly not impossible, it is time-consuming and I had hoped someone had already tackled this issue.

    The frustrating part is that everything was working perfectly in 3.42.

    I’m also surprised that you are unable to replicate this issue. Out of the 4 sites I have updated to 3.5 so far (with 3 more that still need to be updated), the scheduled publishing is failing to work on 1/2 of them. And I’ve ALWAYS had to increase the timeout in cron.php on all of my sites to get scheduled publishing to work.

    Regardless, I’ll clone one of my sites over to a separate server today and try deactivating all plugins and switching themes. I’ll report back my findings.

    Doug Hardy
    Member

    @doug-hardy

    Good afternoon – we’re having the same issue with a site on a multi where we have been using the Headway theme. Not crazy about the idea of switching to the original theme and back to Headway. Lots of customizations.

    Mika hopefully WP will address with another update?

    I want to remind you guys: If we can’t reproduce a problem, it’s hell to fix it :/ I’m not being dismissive, just my hands are tied when a small group of people encounter a rare issue.

    And I’ve ALWAYS had to increase the timeout in cron.php on all of my sites to get scheduled publishing to work.

    That… may be the real root of the problem. Are all these sites on the same server?

Viewing 15 replies - 1 through 15 (of 58 total)
  • The topic ‘Scheduler problem for both posts and back up’ is closed to new replies.