WordPress.org

Forums

Optimize Database after Deleting Revisions
[resolved] Scheduled run not working? (13 posts)

  1. T J
    Member
    Posted 1 year ago #

    This plugin is very helpful. Thank you
    However, I'm unable to use the auto schedule feature.
    It doesn't run.
    I'm using iis6, WordPress 3.6, sbs2003 (windows), MySql
    Otherwise, all else works perfectly.
    Wordpress, itself, does update automatically.
    Thanks for your consideration.

    http://wordpress.org/plugins/rvg-optimize-database/

  2. cageehv
    Member
    Plugin Author

    Posted 1 year ago #

    Hey T J,

    Thanks for the compliments!

    I would suggest to deactivate all plugins (except for the optimizer) and try again.

    Maybe one of the other plugins does 'cron tab stealing'...

    Let me know if that worked!

    Rolf

  3. cageehv
    Member
    Plugin Author

    Posted 1 year ago #

    Hey T J,

    Something else I found with Google:

    When I upgraded to 3.5, cron stopped working for a batch email job. Yesterday, decided to check wp-config and found this:

    define('DISABLE_WP_CRON', true);

    I don't know how that appeared or whether it had anyrhing to do with the upgrade to 3.5, but I disabled the line and cron is again working fine.

    So, please check your wp-config file too!

    Rolf

  4. T J
    Member
    Posted 1 year ago #

    Thanks for your reply.
    Your plugin is the only active plugin, currently.

    I do not have,
    define('DISABLE_WP_CRON', true);
    in my wp-config nor anything relating to "wp-cron".

  5. cageehv
    Member
    Plugin Author

    Posted 1 year ago #

    Hey T J,

    Hummm... weird...

    Can you install a plugin called 'Cron GUI'?

    It will show you what is actually in your cron tab. The question is: is it scheduled at all or not, or is it just not running...

    Rolf

  6. cageehv
    Member
    Plugin Author

    Posted 1 year ago #

    Hey T J,

    From the plugin FAQ:

    "I scheduled the optimization for 8pm but it runs at 6pm (my local time)"
    The scheduler uses the local time of the web server which can differ from your own local time.

    Rolf

  7. T J
    Member
    Posted 1 year ago #

    The time zone is correct.
    The date on the scheduler passes by and doesn't get updated.
    I have it set to run once weekly.
    I am assuming that since the date is not updated that the scheduled job has not run.
    In "cron view", it does list the scheduled event but, with no arguments?
    Aug 23 @3:00 has come and gone.
    A previous event had past by days without running.

  8. cageehv
    Member
    Plugin Author

    Posted 1 year ago #

    Hey T J,

    Poehhhhh... a tough one...

    When you go to the plugin starting page, what is it saying for 'Next scheduled run:'?

    Is that correct or not?

    Rolf

  9. T J
    Member
    Posted 1 year ago #

    Next scheduled run: Aug 23, 2013 @ 3:00 hrs (current server time: 12:37)

  10. cageehv
    Member
    Plugin Author

    Posted 1 year ago #

    Hey T J,

    To be honest, I have no more suggestions here, now... :-(

    It uses quite standard Cron Tab functionality.

    So, it must be some server- or WP setting that prevents it from running.

    I use the scheduler on several of my own websites and it just runs fine (also with WP 3.6)

    I also didn't get any complaints about the scheduler from other users.

    So, at this point I don't know what to do to help you.

    But please keep me informed about your progress on this!

    Rolf

  11. T J
    Member
    Posted 1 year ago #

    Will do. Thanks for your effort

  12. T J
    Member
    Posted 1 year ago #

    Reinstalled wordpress..
    All is working well
    Thanks again for your very useful contribution.

  13. cageehv
    Member
    Plugin Author

    Posted 1 year ago #

    Awesome!

    Cheers!
    Rolf

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Optimize Database after Deleting Revisions
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.