Support » Fixing WordPress » Scheduled Posts Posting Immediately

  • Resolved mwschaff

    (@mwschaff)


    I recently switched from using the classic editor to the block editor supplemented with the Kadence block plugin.

    At this time I noticed that when I try to schedule a post for the next day it publishes immediately. This is despite it showing it as successfully scheduled for a specific date and time in the future. The post shows a future date on the website page.

    I am currently on WordPress 5.8.3. My plans were to update to 5.9 next week but it would be better to wait until there are no issues.

    I haven’t gone through the process of deactivating plugins and testing as this loads up my website with many test posts viewable to the public.

    Any suggestions on what could be causing this? Thanks for your help

Viewing 15 replies - 1 through 15 (of 18 total)
  • Topher

    (@topher1kenobe)

    Can you send a link to a page that’s published prematurely? If you’re logged in you’ll be able to see a Scheduled page early, and it may LOOK published. I also use Kadence and Schedule posts all the time.

    • This reply was modified 7 months, 4 weeks ago by Topher.
    Thread Starter mwschaff

    (@mwschaff)

    Here is a link to a test post scheduled to go live on Feb 17th. However it shows on my home pages etc.

    https://mikeschaffnerphotography.com/test-post/ (now removed)

    • This reply was modified 7 months, 4 weeks ago by mwschaff.
    Topher

    (@topher1kenobe)

    Out of the box WordPress won’t do that, which I’m sure you’ve experienced. That makes me think there’s a plugin or maybe even your theme that’s making that happen. Can you try it with all plugins turned off. and then a different theme?

    It’s also POSSIBLE the date is messed up on our server. That seems really unlikely, but your host could check easily

    Thread Starter mwschaff

    (@mwschaff)

    Thanks. I take it that you confirm it is published and shows a date of Feb 17th? Is that correct?

    I will try setting up a staging site to deactivate all the plugins and use a default theme.

    Topher

    (@topher1kenobe)

    Yep, I see it, and agree I shouldn’t. 🙂

    Thread Starter mwschaff

    (@mwschaff)

    Thanks. I’m removing it now. And working on the staging site setup.

    Thread Starter mwschaff

    (@mwschaff)

    Well it looks like it’s a plugin. With all deactivated it shows scheduled and doesn’t appear. Activate all and it is published.

    Now to wade through them and figure out which one. Was hoping for an easier solution but that’s just how it goes sometimes.

    Topher

    (@topher1kenobe)

    Check this plugin out, it may help: https://wordpress.org/plugins/health-check/

    Thread Starter mwschaff

    (@mwschaff)

    Thanks. I forgot about the troubleshooting mode in Site Health. It does make it easier.

    Thread Starter mwschaff

    (@mwschaff)

    Ok now this is getting weird.

    I used the troubleshooting mode of Site Health
    – all plugins disabled
    – default theme enabled – tried it with 2020 and 2019

    The problem still happened.

    I did notice 2 unusual thing.
    First
    – I would schedule the post in block editor and click on the WP logo in the upper-left corner to get back to the ALl Posts page of wp-admin
    – at this point is showed as scheduled and was not visible on the website
    – if I refreshed the All Posts page or cleared cache the scheduled post immediately changed to published and showed up on the website.

    Second,
    On the trouble shooting page I saw this message

    “When enabling the plugin, wordpress-seo, a site failure occurred. Because of this the change was automatically reverted.”

    I use Yoast SEO no plugin called “wordpress-seo. Disabling Yoast did not resolve the issue.

    I also removed some changes in wp-config.php and the child theme functions.php that were put in shortly before this issue occurred. Taking them out did not solve the issue.

    Topher

    (@topher1kenobe)

    This ONLY happens when using the new block editor? Can you install the Classic Editor plugin and see if it does it there too? You might be onto a real bug here.

    Thread Starter mwschaff

    (@mwschaff)

    It happens with classic editor also. If it were a real bug everyone would have the same issue wouldn’t they?

    • This reply was modified 7 months, 4 weeks ago by mwschaff.
    Topher

    (@topher1kenobe)

    I’m sorry, but I think I’m tapped out. In order to really figure it out I’d need my hands on the code and spend hours testing. 🙁 I’m not available, but if you know a dev they could probably do that for you.

    Thread Starter mwschaff

    (@mwschaff)

    I completely understand – thanks for your efforts. I may end up having to live without scheduling or hopefully this might be fixed when I go to WP5.9.

    Thread Starter mwschaff

    (@mwschaff)

    I signed up for Discord as suggested by @topher1kenobe but they are talking way over my head as my developer skills are limited (to put it very kindly).

    To summarize the issue: When I schedule a WP post in either classic editor or block editor in both WP 5.8.3 or WP 5.9 although the post shows it scheduled when I go to the Posts listings (all posts) it immediately shows as published. As @topher1kenobe confirm it does in fact publish and is visible to all. I first noticed this on a post on January 31st and didn’t have the issue (as best I recall) on a post of January 12th.

    To summarize what I’ve tried:
    – in the troubleshooting mode with all plugins disabled I still had the issue
    – in the troubleshooting mode with all plugins disabled and using the default theme associated with the version of WP I was on (tried with 5.8.3 and 5.9) I still had the issue.
    – I re-installed the core WP files for version 5.8.3 and still had the issue
    – I updated WP to 5.9 and still have the issue
    Basically regardless of WP version with no plugins enabled and using a default theme I have the issue.

    I can’t find very much online about this issue. It seems some possible areas to look at are:
    – Cron job – is a “hook” not being established so it defaults to publish immediately. How I would verify this and fix if it is this is beyond my knowledge
    – Settings – I don’t recall changing any settings prior to this starting but I guess that is possible
    – Permission levels – I don’t recall changing any permission levels prior to this starting but I guess that is possible
    – a real bug in WP -I guess this is possible but seems unlikely as I seem to be the only one with this issue

    If anyone has a suggestion it would be greatly appreciated.

    • This reply was modified 7 months, 3 weeks ago by mwschaff.
    • This reply was modified 7 months, 3 weeks ago by mwschaff.
Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Scheduled Posts Posting Immediately’ is closed to new replies.