Support » Fixing WordPress » Scheduled posts not working

  • Hi,

    Up until recently my scheduled posts no longer work. They just say missed schedule. I have been reading in to this quite a bit in particular cron jobs.

    I have spoken to my hosting provider who said there are no issues with other customers and scheduled posts. I installed a cron viewer on my site and it says:

    “There was a problem spawning a call to the WP-Cron system on your site. This means WP-Cron jobs on your site may not work. The problem was: couldn’t connect to host”.

    So how do I get cron working? Why doesn’t it work for my site now when it did before?

    I used to have backup buddy running and to get that to work I had to add alternative cron true to the config file which added unwanted strings to my web address when it created re-directs. This was due to loopback connections being disabled. Which they always have been by my hosting provider when on a shared hosting package. This is fine as scheduled posts use to work anyway and I am not even sure if the two are related.

    Anyway I have since removed backup buddy and the alternate cron code. But I see no reason as to why this would stop everything working as it worked fine before adding this code.

    The only answers I seem to find are plugin fixes that check for missed posts such as: But this is just a work around not a fix for an issue that I cannot seem to figure out why it doesnt work in the first place.

    I now manually backup my site using BackUpWordpress. But even this plugin informs me of:

    “BackUpWordPress has detected a problem. wp-cron.php is returning a couldn’t connect to host response which could mean cron jobs aren’t getting fired properly. BackUpWordPress relies on wp-cron to run scheduled back ups. See the FAQ for more details.”

    So somewhere something has gone wrong and I don’t know if its in my WordPress installation or an issue with my hosting provider. Can anyone shed some light on the issue?


  • The topic ‘Scheduled posts not working’ is closed to new replies.