Support » Fixing WordPress » Scheduled posts not publishing

  • Hi

    I’ve been using WP for >1 year. In the past I occasionally had issues where if I scheduled a post for the next day or perhaps 4-5 hours in advance it would not post and I’d have to manually post it.

    Unfortunately now no matter how far in advance I schedule to publish, it NEVER publishes. It just says it was “missed”.

    I can see others have had this issue but am unclear of the “fix” as some mention using plugins, others are mucking around in code, etc. Can someone tell me the root cause and if there is an official fix for this? I’m not well versed in changing the underlying code so if that’s required I’d appreciate detailed steps so I don’t screw something up.

    Thank you

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • The scheduling of events uses the WordPress Cron, which requires a visit to a page to initiate it. If there is no traffic, the code never runs, the transients expire, so the date is missed. The update checks also use WordPress Cron. Typically this is not a problem because sites have some traffic, even if it is a search engine bot.

    The solution is to use an external trigger for low-traffic sites.

    Thread Starter roguedadmd

    (@roguedadmd)

    Joy, I don’t understand. A visit to the page by whom and how? If I write a post and schedule it to publish, the page for that post cannot be visited since it is not actually live. Are you talking about a visit to the root page (roguedadmd.com)?

    Last week I had a post scheduled 4 days in advance. The root site definitely had traffic in between the day I scheduled it and the day the new post was supposed to go live, but it still did not post.

    This has also become a more frequent issue recently.

    I am not clear from your response how to rectify this.

    Here’s what one of the systems guys said:

    Install the Health Check plugin, run it, and pay particular attention to what it says about WP-Cron
    Missed scheduled posts are always a broken cron

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Hi! I said that.

    The Health Check plugin has code to specifically check for this type of problem. Try it out, look at the report it gives, post that here. That can help you and us diagnose the issue.

    Thread Starter roguedadmd

    (@roguedadmd)

    Hi all — thanks for the assistance. I installed WP Healthcheck and ran it and below is what it said. It does not say anything about WP-cron so not sure if I’m not seeing the info or if it just didn’t give it.

    ——-

    WP Healthcheck: Your PHP version (5.6.38) is compatible with the current WordPress install. However, in order to get better performance and other improvements, the WordPress team recommends you upgrade your server to PHP version 7.0.0 or greater.

    Dismiss this notice.
    WP Healthcheck: We have found plugins that haven’t been updated in over 2 years: medium.

    Please review them in your plugins page. These plugins may no longer be maintained or supported and may have security and/or compatibility issues when used with the most recent versions of WordPress.

    Dismiss this notice.
    Welcome and thank you for choosing the WP Healthcheck plugin.

    WordPress4.9.8 PHP5.6.38 MySQL5.6.41
    Toggle panel: Transients
    WordPress transients are used to temporarily cache specific data. For example, developers often use them to improve their themes and plugins performance by caching database queries and script results.

    However, some badly coded plugins and themes can store too much information on these transients, or can even create an excessively high number of transients, resulting in performance degradation.

    Total:85
    Size:
    0.14MB
    Clear All Transients Help: Transients
    Toggle panel: Autoload Options
    WordPress autoload options are very similar to transients. The main difference is: transients are used to store temporary data, while options are used to store permanent data.

    All the autoload options, as well as transients, are loaded automatically when WordPress loads itself. Thus, the number and size of these options can directly affect your site performance.

    Total:510
    Size:
    0.17MB
    Top Autoload Options Help: Autoload Options

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    On the Health Check page, look at the Site Status tab, and look for “Loopback request” at the bottom of the page. You will also want to look for the “Scheduled events” line.

    Also, on the Debug Information tab, there is a field that contains a lot of info about your site which you can copy and paste here.

    Thread Starter roguedadmd

    (@roguedadmd)

    Samuel — I think I must be using a different plugin than you recommended because none of those options are on the WP Healthcheck page.

    Could you humor me and look up to see the exact name of the one you recommend? Looking again there are others such as “WP Health (Formerly My WP Health Check)” and “Health Check & Troubleshooting”.

    The one I installed is called “WP Healthcheck.”

    Tanks

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    “Health Check & Troubleshooting”. It’s a featured plugin. Right on the first page of the plugins directory:

    https://wordpress.org/plugins/health-check/

    When you go to the Add New plugin screen in WordPress, and select the “Featured” tab, it’s one of those 6.

    Thread Starter roguedadmd

    (@roguedadmd)

    Ok got it installed now, thank you.

    For scheduled events it says:

    A scheduled event (monitor_dropbox_backup_hook) has failed to run. Your site still works, but this may indicate that scheduling posts or automated updates may not work as intended.

    Here’s what it says for loopback request:

    The loopback request to your site failed, this may prevent WP_Cron from working, along with theme and plugin editors.
    Error encountered: (0) cURL error 28: Operation timed out after 10000 milliseconds with 0 bytes received

    It gives an option to Test Without Plugins.

    Is there any specific from the debug field that would help? Only relevant item seems to duplicate the loopback request failure from above.

    Thread Starter roguedadmd

    (@roguedadmd)

    Any additional thoughts? It seems to state there is a problem but I am not clear how to fix it.

    Hi
    Apologies for jumping in to this thread but I have a question of mine own but for some reason can’t find the form to submit a separate question. Anyway I think this is related to the thread.
    I created a new page on my website and mistakenly scheduled a time for it to be published. That time has elapsed but it remains scheduled and I cannot seem to be able to change it to ‘publish’ mode. The page is meant to be in ‘stealth’ so it has not had any visits. I tried to set up a dummy visit but that did not work.
    I did some research and became informed of wp cron. I downloaded the plugin. I can see that my problem page is ‘non repeating’. I have selected both ‘run now’ and ‘edit’ but that has not resulted in any change. I am wary of using the ‘delete’ option. I don’t want to lose the page.
    I would be grateful of any assistance.
    Thank you
    Paul

    I was struggling with this for a week. Now found a solution here –
    https://updraftplus.com/faqs/my-scheduled-backups-do-nothing-backup-now-stops-midway/

    I used this option –
    Loopback connections are not working?

    Some web hosting providers (one big one: Heart Internet) purposefully (though for no good reason) disable the “loop-back” connects that allows WordPress to run its scheduler. This is also the case if your website is password-protected. If loopback connections are not working (whether deliberately disabled or not), you can try this use WordPress’s alternative scheduling system – instructions here. The instructions amount to one thing: add a line anywhere in the middle of your wp-config.php file as follows (don’t add it too late in the file, or it will take no effect):

    define(‘ALTERNATE_WP_CRON’, true);

    Hope this helps.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Scheduled posts not publishing’ is closed to new replies.