Support » Plugin: Missed Scheduled » Scheduled posts no publishing after upgrade to 3.5

  • In version 3.42 I was able to get schedule posts to work by modifying /wp-includes/cron.php and change the timeout in line 250 from 0.1 to 10. After updating to 3.5, and changing cron.php again, scheduled posts ALWAYS end up as “missed schedule” even if i set the timeout parameter to something incredibly high. I have tried removing all wordpress files and installing a fresh version of 3.5 but the problem persists.

    The Cron View plugin shows each scheduled post as being a one-off event hooked to publish_future_post.

    The Missed Schedule plugin does work, but, by default, it queries the database for missed posts every 5 minutes. Considering we rarely do more than a single scheduled post per day, and maybe 4 per week, querying the database an extra 2016 times per week is a LOT of overheard for 4 posts. In addition, there is a noticeable lag in the site when this plugin is enabled.

    I do have the WP Super Cache plugin enabled, and have read a couple of posts pointing to issues with caching and scheduled posts. But since this WAS working in 3.42, one would think it should be possible to get it working again in 3.5.

    Any suggestions?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator t-p


    I have but didnt see anything related to scheduled posts, or anything that looks like it might interfere with them. :\

    Moderator t-p


    have you tried…
    ■flushing any caching plugins you might be running, as well as server and/or browser caches.
    ■deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). If you can’t get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin (read if you need help). Sometimes, an apparently inactive plugin can still cause problems. Also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old (read for more information on mu-plugins)
    ■switching to the Twenty Eleven theme to rule out any theme-specific problems. If you can’t log in to change themes, you can remove the theme folders via FTP so the only one is twentyeleven. That will force your site to use it.
    ■manually upgrading. When all else fails, download a fresh copy of the file of 3.5 (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first:

    @t-p, yes, I have flushed the cache on the WP Super Cache plugin. I also tried disabling the plugin and then deactivating it as well. I also already tried manually upgrading (see end of first paragraph in OP).

    I have NOT tried deactivating all plugins and/or switching to the twentyten theme, yet. This is a production site so neither of those are an option for me. I’ll have to replicate the site to a separate server in order to go into this level of troubleshooting. While certainly not impossible, it is time-consuming and I had hoped someone had already tackled this issue.

    Moderator t-p


    I have NOT tried deactivating all plugins and/or switching to the twentyten theme, yet. This is a production site so neither of those are an option for me.

    -Those necessary steps in troubleshooting.It’s your choice.

    Make sure you backup everything (including your database) before doing any actions, just in case.

    Phil Broughton


    I have the very same issue and my setup is as follows:
    – Sub-domain with clean WP install
    – .htaccess in subdomain root folder to allow pretty permalinks
    – cron.php timeout adjusted to 20 seconds from 0.01
    – No use of caching
    – All plugins (only 3 anyways!) deactivated
    – Theme installed is Twenty-Eleven (v1.5) where I have a simple child theme ( a couple of extra template files and css formats, no functions)

    This is extremely annoying, there is no “official” feedback from WP on how to go about setting up suitable debug and logging to capture the missed schedule event and wp-cron issue, and I am very reluctant to add more plug-ins that allege to show me perhaps something that I already know rather than how I can fix this ! Keeping it as simple as possible must be the way to fixing it rather than adding more bolt-on checks.

    Phil Broughton


    Update to my last post (apologies for cramming this all in!)

    I reverted to default Twenty-Eleven theme (no child) to see if this would make any difference. At this point, I have pretty much a “vanilla” installation and still the post event misses its schedule (even with my clicking away on the front-end to spawn the cron event!)

    So I added a plugin call “Cron GUI” by Simon Wheatley to expose entries in the wp-cron table and can see the following row that is for a post where it was not published as required on the “Next Date”

    Next Date (GMT/UTC)
    Jan 4, 2013 @ 11:28 (1357298880)

    One-off event


    [0]: 358

    So it leads into “how do I diagnose wp-cron event execution/failure” or worst case “how do I ditch 3.5 and revert to previous release where this was working without an issue?”

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Scheduled posts no publishing after upgrade to 3.5’ is closed to new replies.