Support » Plugin: Revisionize » Scheduled page is not published

  • Resolved George

    (@quantum_leap)



    I revisionized a page, made my changes, saved the draft, then schedule the post to be publised a certain minutes into the future. The post is scheduled, then published a few minutes later but the actual chnages are NOT published. If I go the the revisioned page it seems that it has been published the scheduled time but the page is still in revisionized mode, if you know whay I mean. Only when I hit UPDATE the page with the changes then gets published but that defeats the whole purpose, doesn’t it?

    How on earth do you schedule changes?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author jamiechong

    (@jamiechong)

    Did you schedule the Revision? Or did you schedule the main post?

    You should schedule the Revision (not save draft).

    George

    (@quantum_leap)

    Well yes of course. When I revisionize a page, I am now editing that revision and NOT the original. So I am making a few changes and save the draft just to test it. That’s normal. While I am still editing the revisionized post I make a final edit, save the draft and then schedule it to test if the schedule will go through but it doesn’t. I have already made sure that the cron job has run.

    Plugin Author jamiechong

    (@jamiechong)

    I did a quick test on my end and things seem to work as normal. Will have to keep troubleshooting.

    Can you try scheduling a normal page to verify that works?
    What other plugins are activated?
    Who’s your hosting provider?
    How are you “making sure” the cron job is run? Did you use a tool like Crontrol to force execute the cron? Or did you let it happen naturally by waiting until the scheduled time?
    Are you using WordPress cron? Or is your server setup to run cron?

    George

    (@quantum_leap)

    I have a bunch of plugin activated. Amongst those is Crontrol and Scheduled Post Trigger that makes sures any missed scheduled posts are activated when I visit the homepage.

    Admin Columns Pro
    Adminimize
    Advanced Custom Fields PRO
    All-in-One WP Migration
    All-in-One WP Migration Unlimited Extension
    Autoptimize
    Better Internal Link Search
    Better Search Replace
    Blog Time
    Cloudflare
    CMS Tree Page View
    Code Snippets
    Cookie Notice
    Custom Stock Widget
    Disable Gravity Forms Fields
    Download Monitor
    Duplicate Post
    Elfsight Yottie
    Email Encoder Bundle – Protect Email Address
    Enable Media Replace
    EventON
    EventON – Full cal
    Force Regenerate Thumbnails
    GA Google Analytics
    Gravity Forms
    Gravity Forms CSS Ready Class Selector
    Gravity Forms Salesforce Add-On
    Members
    Members – Role Levels
    MimeTypes Link Icons
    Nav Menu Roles
    Post Types Order
    Postman SMTP
    Public Post Preview
    Quick Page/Post Redirect Plugin
    Really Simple SSL
    Revisionize
    Say What?
    Scheduled Post Trigger
    Shortcode Widget
    Slider Revolution
    TablePress
    Templatera
    UpdraftPlus – Backup/Restore
    Visual Composer Clipboard
    Widget Options
    WordPress Importer
    WordPress phpinfo()
    WP Crontrol
    WP Job Manager
    WP Job Manager – Applications
    WP Job Manager – Emails
    WP Job Manager Field Editor
    WP-Optimize
    WPBakery Page Builder
    WPML Media
    WPML Multilingual CMS
    WPML Sticky Links
    WPML String Translation
    WPML Translation Management
    WPML Widgets
    Yoast SEO

    A normal scheduled page works fine after I visit the homepage to force the cron job. (I didn’t force through Crontrol). Server is not set up to run cron.

    I am using a local install on a PC with the Turnkey linux virtual machine.

    Plugin Author jamiechong

    (@jamiechong)

    Can you try disabling the cron releated plugins – specifically Scheduled Post Trigger and test again.

    A more extreme test is to disable all plugins except Revisionize and test to make sure the basic scheduling is working properly. If it does work we can assume there is a conflict with another plugin.

    George

    (@quantum_leap)

    Ok when I disable Schedule Post Trigger and force-run the cron through Crontrol, it works fine. If I visit the homepage or any other page before I do that, the cron is not actually triggered at all. I have to go to Crontrol and force from there to make it work. How can I solve that issue?

    Plugin Author jamiechong

    (@jamiechong)

    Try to avoid using Crontrol too. Schedule a few minutes into the future and wait…

    WordPress’ pseudo-cron runs when pages load. So if you just refresh the page a few times after the scheduled time has passed – it should work. If not the problem is likely with how you WP install is handling scheduled tasks.

    Regardless, it’s best to setup real Cron to handle the jobs. Something like this:
    https://www.siteground.com/tutorials/wordpress/real-cron-job/

    George

    (@quantum_leap)

    I am sorry but it’s not triggering. With all cron related plugins deactivated scheduled posts are not triggering at all. When I activate Scheduled Post Trigger at least normal post scheduling works. But your plugin seems to not take into account the triggering that happens with Scheduled Post Trigger and I don’t understand why.

    Plugin Author jamiechong

    (@jamiechong)

    Out of the box, WordPress scheduled posts should work without any plugins. It could be your localhost setup, I’m not sure. Down the road I might investigate better integration with the Schedule Post Trigger plugin, but at this stage I cannot help further.

    I suggest setting up real cron on your server. Or try running it manually by going to this URL in another browser tab.
    http://yourdomain.com/wp-cron.php?doing_wp_cron

    George

    (@quantum_leap)

    Ok I understand, thanks anyway.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.