Support » Plugin: WP-Optimize - Clean, Compress, Cache. » Scheduled optimization not working

  • Resolved lamrica

    (@lamrica)


    I have installed this plugin for a couple of weeks and have set the Scheduled Clean-up Settings to weekly but it is not executing the task automatically.

    When I check the Status, it shows:

    WP-Optimize 2.2.11 – running on: PHP 7.2.14, MySQL 10.2.21 – Linux

    There was no scheduled optimization
    Scheduled cleaning enabled, Next schedule: February 13, 2019 6:46 pm – Refresh
    Keeping last 2 weeks data

    It appears the plugin is able to pick up the next schedule date but when it comes to the time, the clean-up task is not happening. Then it will update the next schedule date to a week after.

    I have already checked Cron Events on WP Control. Nothing is overdue, no error shown.

    wpo_plugin_cron_tasks
    WP_Optimize->do_plugin_cron_tasks()
    Twice Daily

    wpo_cron_event2
    WP_Optimize->cron_action()
    Once Weekly

    FYI I have UpDraftPlus installed at the same time and it has been working fine with scheduled auto backup on weekly basis. My site is using WordPress 4.9.9, WooCommerce 3.5.4

    Could you advise how I can fix this issue please? Thank you!

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • May i just say that… i’m experiencing exactly the same thing.

    on the status tab, “last automatic optimizing was at:” which was showing in your screenshot #1 is not showing in my status.

    Plugin Contributor LumberHack

    (@lumberhack)

    Hi @lamrica

    Thanks for bringing this up. I see from your message that the scheduling itself works fine, somehow the process itself does not complete (or errors out). Can you check your error logs for any messages that are relevant please ?

    https://codex.wordpress.org/Debugging_in_WordPress

    Hi @edwards1

    While there are similarities, I think your issue may be different. Will be great if you can open a separate thread and i’ll investigate this for you

    @lumberhack I’ve followed the instructions to turn on the debug mode but there is no error messages. Is there anything else you would suggest me to try? Thanks!

    Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi,

    Apologies for the delay.

    Does the optimisation run if triggered manually?

    Please could you also try setting the plugin to keep only the last 1 week of data?

    If triggered manually, it seems to work but not entirely. Especially for database tables, I have to do it several times manually in order to reduce the overhead size.

    I have changed the setting to keep 1 week of data. Let’s see if that will help on the next scheduled date of clean up.

    Same, scheduled clean up did not happen 🙁

    @dnutbourne the schedule clean up never happen on my website. Is there anything you can suggest to fix this issue? I’ve updated to your latest version of 2.2.13 and WordPress on 4.9.10 now. Thanks!

    Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi,

    Apologies for the delay. I will consult with my colleagues

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Scheduled optimization not working’ is closed to new replies.