Support » Plugin: Robin image optimizer — save money on image compression » Scheduled optimization not running

  • Hello, i try to set up scheduled optimization, but it doesn’t seem to run.
    It starts with the firts 3 images and then i see nothing in the log on the bottom.
    wp-cron is enabled.

Viewing 8 replies - 1 through 8 (of 8 total)
  • I not started the “run now” optimization and i get in the log

    Error: Attachment cannot be optimized. File “(/home/xxx/public_html/wp-content/uploads/2010/06/xxx.jpg)” doesn’t exist.

    How is that possible ?

    When i upload new images (i have the “Auto optimization on upload” enabled) everything works fine.

    The problem is with the old image files.

    Plugin Support webtemyk

    (@webtemyk)

    Hi,

    Please, check if this file actually exists. http://site.com/wp-content/uploads/2010/06/xxx.jpg

    No the files actually don’t exist.
    I just found out.
    But the problem remains.
    The scheduled optimization is not working.
    wp-cron is enabled.

    Plugin Support webtemyk

    (@webtemyk)

    In the “Settings” tab of the Robin has a Scheduled optimization settings https://imgur.com/qx44R8G
    You can choose how many images and with what time interval to optimize

    I made the correct settings, i started the the scheduled optimization, but nothing happens in the optimization log.

    Plugin Support webtemyk

    (@webtemyk)

    After updating the page in the log appears nothing?

    Turn on the error log in the settings Robin – “Error log” option, and send me these logs.

    ysintos

    (@ysintos)

    Here it is part of the error log:

    12-07-2019 04:14:31.1562904871.2278 [116.203.184.52][5d2809][info] Start cron job. Scope: media-library
    12-07-2019 04:14:32.1562904872.1018 [116.203.184.52][5d2809][error] Failed to find original attachment #68440 located in *empty path*. Skipping optimization. This may be caused due to bug in wp_get_attachment_metadata() function, which returns false for attachment meta
    12-07-2019 04:14:32.1562904872.105 [116.203.184.52][5d2809][error] Failed to find original attachment #68441 located in *empty path*. Skipping optimization. This may be caused due to bug in wp_get_attachment_metadata() function, which returns false for attachment meta
    12-07-2019 04:14:32.1562904872.1084 [116.203.184.52][5d2809][error] Failed to find original attachment #68443 located in *empty path*. Skipping optimization. This may be caused due to bug in wp_get_attachment_metadata() function, which returns false for attachment meta
    12-07-2019 04:14:32.1562904872.1138 [116.203.184.52][5d2809][error] Failed to find original attachment #68444 located in *empty path*. Skipping optimization. This may be caused due to bug in wp_get_attachment_metadata() function, which returns false for attachment meta
    12-07-2019 04:14:32.1562904872.1185 [116.203.184.52][5d2809][error] Failed to find original attachment #68445 located in *empty path*. Skipping optimization. This may be caused due to bug in wp_get_attachment_metadata() function, which returns false for attachment meta

    Plugin Support webtemyk

    (@webtemyk)

    Send the entire log. There is an Export button

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.