Support » Plugin: Schedule Posts Calendar » Scheduled drafts are being published immediately when clicking Schedule button

  • Resolved j.dominionated

    (@quickbeforeitmelts)


    For the last few weeks I have been having this issue with increasing regularity. I thought It was something I did wrong, but in deactivating this plugin I’ve discovered the issue has stopped, so I want to bring it to your attention.

    Here’s the sequence of events as they have been happening:
    1. I begin drafting a post, and use the calendar to schedule the post in the future.
    2. I save the draft of the post with the scheduled date as I work; the calendar displays the scheduled date as when the post will be published.
    3. After making further revisions to the draft (sometimes in the same work session, sometimes after returning to it later on) and feeling it is ready to publish, I click on SCHEDULE, so that the post will be automatically published at the scheduled time.
    4. Instead of scheduling the post at the assigned day and time, the post is immediately published.

    Basically, I schedule the post, work on writing it, and when I’m finished and ready to publish it, the scheduled date is overwritten and it publishes immediately.

    Any thoughts on this?

    https://wordpress.org/plugins/schedule-posts-calendar/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Greg Ross

    (@gregross)

    I can’t reproduce the issue, are you using any other plugins that effect the scheduling or editing of posts?

    j.dominionated

    (@quickbeforeitmelts)

    Thanks for the quick reply, Greg.

    The only other plugins I’m currently using that could possibly interfere are Edit Flow
    and User Role Editor. I’ve been using them for a number of months with no previous issues.

    Plugin Author Greg Ross

    (@gregross)

    Are you using the pop-up calendar option or the static one?

    j.dominionated

    (@quickbeforeitmelts)

    Inline option. Never used the pop up.

    Plugin Author Greg Ross

    (@gregross)

    It must be a conflict of some kind but I’m at a loss to explain it. The calendar code doesn’t change the publish date/time until you click on the calendar so it should never randomly change it.

    The only thing I can think of is that somehow the “Today” button is getting activated.

    If your comfortable editing a javascript file, edit “wp-content/plugins/schedule-posts-calendar/schedule-posts-calendar.js”, lines 75-77 should currently be:

    function scp_calendar_today()
    	{
    	var currentDate = new Date();

    change them to:

    function scp_calendar_today()
    	{
            alert( "Today button activated!" );
    	var currentDate = new Date();

    This will pop up a browser dialog whenever the today code is run.

    Then try and reproduce the issue and let me know if you see the alert.

    j.dominionated

    (@quickbeforeitmelts)

    I have done some digging myself, and think the conflict may have come from another plugin that is no longer being updated. I have since disabled it and have not had any further issues.

    Thanks for your help and support. Schedule Post Calendar is, in my opinion, a WordPress essential.

    Thanks.

    Plugin Author Greg Ross

    (@gregross)

    No problem, just for future reference, what was the other plugin?

    j.dominionated

    (@quickbeforeitmelts)

    It was Edit Flow.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Scheduled drafts are being published immediately when clicking Schedule button’ is closed to new replies.