Support » Plugins and Hacks » Scheduled database backups no longer working

Scheduled database backups no longer working

Viewing 15 replies - 16 through 30 (of 34 total)
  • I’m running on a dedicated server and still having this issue. Just tried disabling database cache and a scheduled post still failed.

    I think the solution is just to set up a cron job to call wp cron like Frederick mentioned, maybe every 5 minutes or something. Actually is 5 minutes too much? My understanding is that WordPress calls wp-cron.php basically everytime any page is accessed so it should be okay right?

    I think I am confused now too. I know for a fact that I can go back to the previous version of W3 Total Cache and all of this will work correctly. I can’t speak for everybody here, but ONLY upgrading to the latest version of W3 Total Cache is what broke my setup. This is why it’s hard for me to accept that it’s a bug in WordPress 3.5.

    I can only repeat myself. The problem came with the latest W3 Total Cache security update which breaks W3 Total Cache’s file/disc based cache. This results in wp-cron not working anymore.

    Two ways to fix this:

    1. Fix it yourself. It is only one line of code to insert. I wrote about it here: http://wordpress.org/support/topic/updated-w3cache-and-now-very-slow?replies=6#post-3710678
    2. Disable W3 Total Cache’s file/disc based cache or switch to a different object cache driver.

    Holy crap. ptnplanet, you have my apologies. I actually bookmarked your link when you posted it to “check it out later” and totally forgot about it. Then I just got distracted with all of today’s new replies. So sorry. Yes, you have a valid fix for this and it appears to have worked.

    Thank you.

    What is amazing is that the author read this and still after he said:

    @ptnplanet is right.

    We do not have an updated version that fix this.


    I have disabled the cache to see if this helps.

    I use Backwpup and have the same issue. DIsabling database/object cache doesn’t seem to help, and backups just hang in limbo when uploading to dropbox. For now I just deactivate W3 while doing backups and reactivate when they’re complete. Hope this gets fixed soon.

    Plugin Author Frederick Townes


    Can anyone let me know if issues still persist in the last version?

    @frederick Yes! It’s still there.
    I’m using BackWPup with W3TC, and crop jobs aren’t working. Any fix?

    I have just found out cron jobs are not working now as of yesterday when I went to the latest version and I am NOT using disk caching I am using APC.

    This was working up until I updated to the latest version of the Cache plugin. I had not had any missed posts or anything so now I am not sure what in the new version broke the previously working scheduled posts.

    Same problem with the UpdraftPlus plugin, which I maintain – we’ve had a few user reports traced back to W3 Total Cache. Cron was working, but when the scheduled task looked for its transients, set 5 minutes earlier with an expiry time of 9 hours, they weren’t there. Disabling W3 Total Cache fixed the problem in each case.

    So can ANYBODY determine what in W3TotalCache is preventing CRON from working? Seriously, they are not speaking up and it’s frustrating. Can you as another plugin author debug the settings and see if there is tickbox or tweak someplace that gets CRON working again since you also rely on it?

    I am sure once we find it ALL things broken with CRON like scheduled posts and backups wil again start working.

    The W3TtotalCache people need to start speaking up and helping here! Frederick please HELP this is not an isolated issue with your plugin!

    Please get in touch with us directly about the issue if you’re still having problems: http://www.w3-edge.com/contact/

    We are unable to monitor all the forum threads about W3TC and can provide the best support when there’s an email to track and a site to test on. Sorry for the trouble.

    SO I reverted back to and got things working again. However, something I discovered is you need to not only DISABLE object cache but you need to REMOVE the object-cache.php file from /wp-content for CRON jobs to start working again.

    I am still working on the new version but nothing seems to work. I have filed a bug that it must be de-activated for it to work. I also have a manual CRON job running every 5 mins now and that works when the new one is not activated. I will need to stay on until they work out this bug.

    Having problems with wp-cron.php. WP 3.5.1 & W3 on a WP Multisite install. Deactivating W3 Total Cache fixed this issue…hopefully this gets resolved soon.

Viewing 15 replies - 16 through 30 (of 34 total)
  • The topic ‘Scheduled database backups no longer working’ is closed to new replies.