Support » Fixing WordPress » Schedule Posts Not Working in 2.5

  • I upgraded to 2.5 – everything went well, except for two of my most favorite plug-ins crapping out (Image Manager and PodPress). however, I noticed this morning that the publish date and time is not working correctly.

    When I click the edit button and change the time, then click save or publish, the post gets published at the current date and time and not in the future.

    I have disabled all plug-ins and it still does not work.

    Any help would be greatly appreciated as being able to properly schedule a post is vital for my website.

Viewing 15 replies - 31 through 45 (of 99 total)
  • bumping.

    anyone know what is happening to fix this?

    i am having difficulties with post scheduleing too. However, mine wont even let me open the “edit” post publishing date. It stopped working about 24-48 hours ago.

    At the bottom of my internet explorer browser window it says, “Done with page errors”. I tried downloading mozilla firefox and still has problems. Deleted Cache/Cookies/Temp. Internet files. Nothing seems to be working, Any Ideas?

    i haven’t tried again in the last 24 hours but I always use firefox

    this is still not working. i had a post scheduled to go up. now it says “14 hours ago” and unpublished. i scheduled the post about 10 days ago so it should have gone up automatically

    I’m having the same problem with WordPress 2.6. My scheduled posts worked fine before but after I switched my website to a new server/host, I started getting this problem.

    I wouldn’t mind trying that script that AlfietheCoder posted, but I don’t understand where I’m supposed to put all that code.

    Any help is appreciated.

    good idea!

    anyone? this is a problem in 2.5 and 2.6

    can anyone help? it appears to be code that goes in the sql not the theme editor.

    any other fixes???

    has anyone got a simple easy to implement solution for this problem?

    I am using NearlyFreeSpeech.net for my hosting.

    Following this from talltree over in the tracker fixed it for me:

    status changed from closed to reopened.
    version changed from 2.2 to 2.5.
    resolution deleted.
    I had this problem too while using nearlyfreespeech.net hosting and future posts not working. I made this change to the code and now it works

    in /includes/cron.php search for

    if ( $argyle )
          fputs( $argyle,
               "GET {$parts['path']}?check=" . wp_hash('187425') . " HTTP/1.0\r\n"
             . "Host: {$_SERVER['HTTP_HOST']}\r\n\r\n"
          );
    }

    and replace with

    if ( $argyle ){
          fputs( $argyle,
               "GET {$parts['path']}?check=" . wp_hash('187425') . " HTTP/1.0\r\n"
             . "Host: {$_SERVER['HTTP_HOST']}\r\n\r\n"   );
          fflush($argyle);
          fgets($argyle);
          fclose($argyle);
       }
    }

    Thanks

    Here’s the link:
    http://trac.wordpress.org/ticket/3742

    A very, very frustrating problem. Makes WordPress unusable if you’re working ahead.

    Thanks,
    Branson

    thanks branson for the info…although it didn’t seem to work for me. anyone else give it a try?

    ditto….no joy {host: 1and1.com, wp 2.5.1}

    I asked my web host about it and it seems that it was a security issue with them (a firewall or something). They removed it, and since then it seems to be working.

    Can someone from WordPress please respond to this thread and identify if this is a known bug or if people here just have configuration issues? How is the scheduling “supposed” to work? Should there be a cron job or something running to load a page that checks for posts that need to be published? I set up my own server, so I can do whatever; no issues with hosting providers. But how is it supposed to work?

    ontheedgecomics – what host are you with? I’m with bluehost

    I have found some more info on this but I’m not 100% certain what to do

    this thread says to create a new php file. Where would I put this file? in the wp-content directory???

    and another thread says

    The software regression ( http://en.wikipedia.org/wiki/Software_regression ) occurred in 2.1, and people don’t notice it (in any version later) until they write a future-dated post AND their host has a particular, yet common, configuration.

Viewing 15 replies - 31 through 45 (of 99 total)
  • The topic ‘Schedule Posts Not Working in 2.5’ is closed to new replies.