WordPress.org

Support

Support » How-To and Troubleshooting » Schedule Posts Not Working in 2.5

Schedule Posts Not Working in 2.5

  • I upgraded to 2.5 – everything went well, except for two of my most favorite plug-ins crapping out (Image Manager and PodPress). however, I noticed this morning that the publish date and time is not working correctly.

    When I click the edit button and change the time, then click save or publish, the post gets published at the current date and time and not in the future.

    I have disabled all plug-ins and it still does not work.

    Any help would be greatly appreciated as being able to properly schedule a post is vital for my website.

Viewing 15 replies - 1 through 15 (of 99 total)
  • Update: it appears that it is working if you schedule something at least an hour in advance. ??? Something scheduled within the half hour still publishes immediately.

    The functionality that checks whether the post should be in the future or not depends heavily on the offset value for your blog being correct. Do you have the correct setting for the GMT Offset in the main settings page? Did you remember to correct it for daylight savings time? That could make it an hour off.

    Dealing with daylight savings can suck. If you use PHP 5.1 or up, I wrote this little plugin as a demonstration of the “right” way to do this sort of thing. I use it on my own blog. Basically, it auto-corrects the offset setting based on a standard timezone name that you specify. I use it on my own site, it’s quite handy: http://ottodestruct.com/wpstuff/timezone.zip

    Only works with PHP 5.1 and up though. That’s when PHP added all the good timezone functionality. However, the plugin is smart enough not to let you activate it if it won’t work.

    Yes, UDT is set correctly, so that isn’t the issue.

    I’m having the same problem, kinda.

    If I schedule a post it works fine. But, if I need to change the time and/or date of that post, it won’t change. I’ve tried marking it as unpublished and resetting the time/date, but it still goes back to the time/date I originally set.

    Any suggestions? I really need this feature to work correctly.

    I think everyone is having the same problem. I end up having to hack the database record for each post that I want to schedule.

    Scheduling worked perfectly in 2.3, and it seems the problem was introduced in 2.5.

    Please fix this functionality, you cannot imagine how essential it is.

    I’m having the same problem, if I schedule something, it doesn’t post, and after the time I set it to publish, it will say “3 hours from now” or however long it is. Definitely needs to be fixed, I can’t be on posting all the time.

    I’ve got two scheduled posts that still haven’t published, one was scheduled for the 15th, the other for the 20th. Both are still listed as scheduled, both show the correct times when they should have published but didn’t. My timezone info is correct, I see the proper time listed on my General settings page. Using 2.5.1.

    I too am having the same problem. This was working just fine in 2.3 but now seems to be broken in 2.5.1. I have checked the UDT settings which are correct. None of my post ever self publish and they always say Scheduled. My WordPress is running on the http://www.webhost4life.com servers on an IIS box.

    [SOLVED] I removed the WP_SECURITY module and all is well again!!!

    Same problem here too since upgrading to 2.5.1 from 2.3. Posts Schedule but never switch over to Published status, and the clock seems to run in reverse after the scheduled time (eg 8 minutes after scheduled time the Manage page says ‘8 minutes time’ rather than ‘8 minutes ago’).

    This is rendering WordPress almost less than useless for me at the moment. Has anyone come up with a solution as yet? (wfunderberg: what’s the WP_SECURITY module? Is this a Plug-in you had, or part of the Core?)

    Are any Developers watching this thread at all?

    Same exact problem as above. Problem persists even after upgrading to a new server. I’ve tried the “/includes/cron.php” fix from this thread http://trac.wordpress.org/ticket/3742 with no luck. Also looked at the “node” fix but no one provided details for it. Just like no details were provided for the wp_security fix above. If anyone can provide more info it would be of great help.

    I’ve also noticed that any post that is scheduled within the next 24 hours gets published *immediately* and doesn’t go to Scheduled status.

    I was attempting the CRON.PHP fix referred to above and didn’t want to wait a day to see if it worked, so set the publish date/time to an hour+10 mins ahead (to allow for possible DST discrepancies). Further experimentation showed that the limit was 24 hours. Over that, and it goes to ‘Scheduled’ as required (but still doesn’t flip to ‘Published’).

    I also expressed my dilemma with this WordPress 2.5.1 publishing problem in a separate post.

    I thought I was alone with this situation, but I’m also surprised that there’s not much talk elsewhere about this pre-publishing problem.

    Babysitting my blogs is no fun, and I look forward to a solution.

    Just wanted to add to this to try to get some more attention for this issue. I am having this issue as well on 2.5.1 upgraded from 2.5 (fresh install). This extremely useful feature is something that I used on other blogs, so I am looking forward to a fix!

    i’d like to also add attention back to this, as it worked fine for me before, and now does not as well on 2.5.1

Viewing 15 replies - 1 through 15 (of 99 total)
  • The topic ‘Schedule Posts Not Working in 2.5’ is closed to new replies.
Skip to toolbar