Support » Plugin: EWWW Image Optimizer » Schedule kills server

  • Resolved hiroprot

    (@hiroprot)


    I just installed the plugin version 1.8.4 and configured it to run the scheduled optimization. Ten minutes later, at the next full hour, my server stopped responding. The only thing I got was a timeout, even on the CPanel most of the time.

    Once I renamed the plugin directory via FTP everything was back at normal again.

    From what I could see in CPanel the load strangely was not too high. It said:

    Server load: 0.51 (1 CPU)

    Memory load was around 50%.

    I disabled the scheduled optimization and am now running the bulk optimize and that seems to play nicely.

    https://wordpress.org/plugins/ewww-image-optimizer/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Now that I am trying to optimize around 400 existing images with the bulk optimization tool I am noticing that it only optimizes around 8 images. Then it says operation interrupted.

    At the same time the server is getting slower and slower. After the optimization has been interrupted speed is normal again.

    Would be nice to have some kind of throttling that does not impact the server.

    I opened a ticket with my provider and only minutes later the server was fast again.

    I then restarted the bulk optimization process and it seems to work much better now. It has already optimized 131 images while the site is still very responsive.

    So this may have been a false alarm.

    Plugin Author nosilver4u

    (@nosilver4u)

    Actually, there IS a throttling option. It definitely sounds like your provider was throttling you though.
    Just so you know, the Scheduled Optimization will only optimize things outside of the Media Library. For example, theme images, and any folders you have configured in the ‘Folders to optimize’ option. It will also do some buddypress and/or wp symposium images. It is basically designed for catching images created outside of anything this plugin can automatically optimize. It also keeps track of what has already been optimized, and skips those on subsequent runs. It is recommended to run the ‘Scan & Optimize’ from the Bulk Optimize page before you turn on Scheduled Optimization for the first time.

    Hope that helps a little.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Schedule kills server’ is closed to new replies.