WordPress.org

Support

Support » Plugins and Hacks » [Resolved] scan stops at random points

[Resolved] scan stops at random points

  • Brent
    Member

    @illegit

    hello

    i’m using wordfence for a couple sites and for some sites it works well, for some it doesn’t. My scans are stopping randomly, most of the time they stop when they reach the following points:

    [Feb 17 06:38:33]Scanning file contents for infections and vulnerabilities
    [Feb 17 06:38:33]Scanning files for URLs in Google's Safe Browsing List

    i’ve searched for solutions but unfortunately i haven’t found any. i tried setting the maximum execution time to 15 (max_execution_time value is 30) but i still couldn’t get my scans to finish. could you help with this please?

    thanks.

    https://wordpress.org/plugins/wordfence/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Wordfence
    Participant

    @mmaunder

    Can you check your system information using the link at the bottom of the Wordfence options page and let me know what memory_limit is set to?

    Regards,

    Mark.

    Brent
    Member

    @illegit

    hi,

    thanks for the reply. memory limit is set to 128mb. i was able to get this issue fixed by manually setting max_execution_time to a much higher value.

    Plugin Author Wordfence
    Participant

    @mmaunder

    Thanks, what value did you set it to?

    Regards,

    Mark.

    Brent
    Member

    @illegit

    30000 😮

    Plugin Author Wordfence
    Participant

    @mmaunder

    ooh. That’s interesting. I’m not sure what Wordfence even does when you set it that high. Actually I just looked at the code and it turns out Wordfence won’t fork at all but will run the entire scan in a single process. So if that works for you that’s great news. I might try suggesting that to other customers who’s scans aren’t returning after forking.

    Regards,

    Mark.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] scan stops at random points’ is closed to new replies.