• I have an issue with one of our sites

    The Wordfence scan is not completing and appears to be stuck at the point where it says
    Done file contents scan

    After some time a message appears to say the scan appears to have failed.

    I tried the troubleshooting methods below

    Increased the max execution time in php
    Increased the performance option in WF Options Maximum execution time for each scan stage to 20
    Enabled scan images, binary, and other files as if they were executable
    Enabled debugging mode
    Set WordFence to delete tables upon deactivation and deactivated, re-activated and reconfigured the firewall.
    Set scan back to Standard Scan

    Checked error logs for issues but dont appear to see anything to indicate why the scan fails.

    Last three lines of log when it stops scanning

    [Feb 03 20:09:44] Done host key check.
    [Feb 03 20:09:44] Finalizing malware scan results
    [Feb 03 20:09:44] Done file contents scan

    Anyone know how to resolve this issue?

    • This topic was modified 2 years, 5 months ago by thyran.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support wfpeter

    (@wfpeter)

    Hi @thyran, thanks for your message.

    It looks like you’ve already tried a good number of troubleshooting methods, I will just provide our documentation here in case there’s anything that you’ve not covered: https://www.wordfence.com/help/scan/troubleshooting/

    In the mean time with your scan, I’ve noticed you didn’t mention starting scans remotely from the Wordfence > Tools > Diagnostics > Debugging Options section. Does this help at all? It may also be wise to clear site caches whether that’s server-side or a WordPress plugin as this can time-to-time cause issues that need clearing out.

    Let me know how you get on!

    Peter.

    Thread Starter thyran

    (@thyran)

    Hi There

    Thank you for the feedback.

    Yes have tried all the options in
    https://www.wordfence.com/help/scan/troubleshooting/

    Clearing cache server and browser side has no effect.

    Enabling starting scans remotely reports a scan engine error: The signature on the request to start a scan is invalid. Please try again.

    https://snipboard.io/eoPBgZ.jpg

    Without this option enabled scans are still stuck at” Done file contents scan
    https://snipboard.io/mvp7ER.jpg

    Plugin Support wfpeter

    (@wfpeter)

    Hi @thyran,

    I have been looking at the scan stages that appear after this, and the immediate line is to report: “Scanning file contents for infections and vulnerabilities”. The issue could be with communication to our servers and back in this case because infections and vulnerabilities will be based on our known data/signatures.

    Can you send a diagnostic report to wftest @ wordfence . com? You can find the link to do so at the top of the Wordfence > Tools > Diagnostics page. Then click on “Send Report by Email”. Please add your forum username where indicated and respond here after you have sent it.

    NOTE: It should look as follows – Screenshot of Tools > Diagnostic > Send by Email

    Thanks again,

    Peter.

    Thread Starter thyran

    (@thyran)

    Hi There
    I have emailed the report as requested
    Thank you

    Thread Starter thyran

    (@thyran)

    Any news on this? Scan still failing at the indicated point.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Scan stops at Done file contents scan’ is closed to new replies.