Support » Plugin: Wordfence Security - Firewall & Malware Scan » Scan stop request received.

  • slapbox

    (@slapbox)


    Scans always stop immediately. We’re using a self signed certificate between our server and Cloudflare, and the Cloudflare certificate for public facing connections.

    I saw a mention that this is caused by cURL validating the SSL certificate, but add_filter('https_ssl_verify', '__return_false'); makes no difference.

    I saw a mention of initiating the scans remotely, but I don’t see any option like that?

    I’ve tried everything I’ve found, including memory usage tweaks – but the result is invariably the same.

    We also tried everything in https://www.wordfence.com/help/scan/troubleshooting/#if-your-scans-arent-starting

    Thanks for reading!

    • This topic was modified 7 months ago by slapbox.
Viewing 9 replies - 1 through 9 (of 9 total)
  • wfdave

    (@wfdave)

    Hi @slapbox,

    Can you try enable remote scans? The option can be found under Wordfence -> Tools -> Diagnostics -> Debugging Options.

    For example: https://i.imgur.com/QiMG6dG.png

    Dave

    Hey @wfdave thank you for your reply!

    Unfortunately remote scan didn’t work, but that did help me find the debugging option which allows me to see the cause of failure, which is, Scan process ended after forking.

    I read the relevant part of the scan troubleshooting docs, but I’m unclear on this bit: “Memcache may have to be restarted twice in order for the object-cache to get rid of the saved cron key.”

    We are using memcache via W3 Total Cache, but purging the cache, disabling it, disabling W3TC, and rebooting the server all fail to remedy the issue.

    How would one restart memcache twice in this scenario, and is that relevant in an environment which includes define('DISABLE_WP_CRON', true);

    Crispypata

    (@carlodimaandal)

    Having the same issues. I have three websites across two different web hosts all having the same issues/symptoms.

    pauljbenedict

    (@pauljbenedict)

    I have run into the same issue, also on 3 sites.

    @wfdave, any ideas? Issue persists.

    I have the same issue on one of my websites both hosted on the same server in Cloudways for 2 days,the one failed in scanning has Redis configured with Redis Object Cache plugin,the other has no Redis configured and runs scanning process well.
    But the one has issue with scanning still failed to scan even after disabling Redis Object Cache plugin and switching to default theme.

    Having the same problem, also using cloudflare: “Scan process ended after forking”. Any luck resolving this?

    @wfdave we launched a new version of our site with a lot of changes, but the issue persists. An otherwise great plugin, but I’d love to get this working!

    Crispypata

    (@carlodimaandal)

    Anyone had any luck with this?

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.