Wordfence Security
[resolved] Scan starts but doesn't seem to do anything (7 posts)

  1. johnrhopkins
    Posted 1 year ago #

    I just installed Wordfence on two sites. Both sites, when I click "Start a Wordfence scan" it appears to begin. I see the red block in the bottom right that says "Wordfence is working..." then that goes away a moment later.
    I don't see any indications of activity after that.

    Here is a quick video that illustrates what I'm seeing: http://screencast.com/t/Tj0rgQIN0


  2. sdayman
    Posted 1 year ago #

    How long did you wait? Granted, I have my refresh rate set to 2 minutes, but sometimes it takes a minute before my scan starts. Maybe that's because of my refresh rate.

    Try going to the Wordfence Options page and enable Debugging near the bottom. That provides a more verbose activity log.

  3. johnrhopkins
    Posted 1 year ago #

    I went back to one of the sites today and found that I had one line in the Scan Detailed Activity. Then I tried scanning again after enabling debug mode and got the following lines:

    [Aug 16 16:25:16] CURL fetching URL: https://noc1.wordfence.com//v2.11/?v=3.9.2&s=http%3A%2F%2Fsalonnvslc.com&k=0b3feedd73808d5f2fdcfc630dad8291899271c165d8c8f3751d43c06f5a712c37cdf31c947ceb23ce1fdfd870b8251450aec232fd4d2e1a00fddffdda67bbdff0a697cc2b989ef47a3b8233924720cc&action=ping_api_key
    [Aug 16 16:25:40] Ajax request received to start scan.
    [Aug 16 16:25:40] Entering start scan routine
    [Aug 16 16:25:40] Got value from wf config maxExecutionTime:
    [Aug 16 16:25:40] Got max_execution_time value from ini: 30
    [Aug 16 16:25:40] getMaxExecutionTime() returning half ini value: 15
    [Aug 16 16:25:41] Test result of scan start URL fetch: array ( 'headers' => array ( 'date' => 'Sat, 16 Aug 2014 22:25:40 GMT', 'server' => 'Apache/2.0.52 (Red Hat)', 'x-powered-by' => 'PHP/5.3.6', 'set-cookie' => array ( 0 => 'PHPSESSID=9a0b22bf807dac7ff0cee01a6033d1f2; path=/', 1 => 'wfvt_-1706430247=53efda655f36f; expires=Sat, 16-Aug-2014 22:55:41 GMT; path=/; httponly', ), 'expires' => 'Wed, 11 Jan 1984 05:00:00 GMT', 'cache-control' => 'no-cache, must-revalidate, max-age=0', 'pragma' => 'no-cache', 'x-robots-tag' => 'noindex', 'x-content-type-options' => 'nosniff', 'x-frame-options' => 'SAMEORIGIN', 'content-length' => '12', 'connection' => 'close', 'content-type' => 'text/html; charset=UTF-8', ), 'body' => 'WFSCANTESTOK', 'response' => array ( 'code' => 200, 'message' => 'OK', ), 'cookies' => array ( 0 => WP_Http_Cookie::__set_state(array( 'name' => 'PHPSESSID', 'value' => '9
    [Aug 16 16:25:41] Starting cron with normal ajax at URL http://salonnvslc.com/wp-admin/admin-ajax.php?action=wordfence_doScan&isFork=0&cronKey=3a7e659f1ae6789c4b1baaaa
    [Aug 16 16:25:42] Scan process ended after forking.

  4. sdayman
    Posted 1 year ago #

    Just for kicks, try enabling: Disable config caching
    This feature was a frequent cause of my scans hanging.

  5. Wordfence
    Plugin Author

    Posted 1 year ago #


    Please try enabling the option on your Wordfence options page at the bottom to start all scans remotely. This may solve the issue.



  6. johnrhopkins
    Posted 1 year ago #

    Thanks Wordfence. That sorted it.

  7. Wordfence
    Plugin Author

    Posted 1 year ago #

    That's great news!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Wordfence Security
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.