Support » Plugin: WP Broken Link Status Checker » Scan is crawling but not showing any results

  • Resolved dax20798

    (@dax20798)


    Hi,
    I love this plugin and it has worked for most of the sites I maintain, however for one of my sites, the scan has been crawling for about 14 minutes but has not shown a single result. It says ‘No results, 1 enqueued, 2 processing’, and it’s been that same message the entire 14 minutes. It seems to be caught up on something. Any help in resolving this issue would be appreciated…thank you!

    https://wordpress.org/plugins/wp-link-status/

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Contributor Pau Iglesias

    (@pauiglesias)

    Hi dax20798, thanks for reporting the issue,

    There are several situations where the plugin can fail, like sites with password protected directories, or scanning sites on local or development server by modifying the hosts file.

    It is possible to know the website where this issue happens? You can reply here or send me a message from the contact form:

    Contact

    Regards,
    Pau

    dax20798

    (@dax20798)

    Hi sorry for late reply.

    It is the website orwacab.org . Do you need log-in info for WordPress backend?

    Plugin Contributor Pau Iglesias

    (@pauiglesias)

    Hi, after few checks, I have not seen anything in the content that may cause the problem, but I’m seeing you are using Visual Composer, maybe there is a conflict with this plugin.

    If you want I can log-in to see the posts and pages content and check why the plugin can’t parse links properly.

    Another option is to export to XML all content (via Tools menu) and send me the file.

    My e-mail adddres is:

    info (at) seedplugins.com

    Kind regards,
    Pau

    olivier83

    (@olivier83)

    Hello,
    I have the same issue and I use visual composer as well.
    My website is creativinn.com
    I got this message:
    4/94 entries
    Yesterday at 22:59 — Running time 21 hours
    2 results·2 unique URLs·1 enqueued·1 processing

    Kind regards,
    Olivier

    Plugin Contributor Pau Iglesias

    (@pauiglesias)

    Hi olivier83, thanks for reporting the issue,

    it seems something is stopping the crawler,

    it is possible a login access, or exporting the content to XML and send the file?

    My contact e-mail is info (at) seedplugins.com

    Regards,
    Pau

    same problem, with visual composer too

    Plugin Contributor Pau Iglesias

    (@pauiglesias)

    Hi, last version 1.0.3 solves issues related to the plugin installation on HTTPS sites, and also a problem with generated files permissions on Hostgator (and possibly other hosts).

    To fix the problem with Hostgator you need to update the plugin and remove the generated file wp-link-status-salt.php located at wp-content/ directory. Then this file will be generated again by the plugin with the right permissions.

    Kind regards,
    Pau

    Hi, scan doesnt move on. No results. WP4.6.
    Tried to deaktivate some plugins above. Deleted the wp-link-status-salt.php.
    Still no scanning.
    Is there log for to see what the blocking of scan is?

    Greetings
    Deexperte

    Plugin Contributor Pau Iglesias

    (@pauiglesias)

    Hi deexperte, the plugin has a internal log, but only used for development. What’s your website? to look if there is any restriction.

    Hi Pau,
    Website:
    schellinger-smb.de

    Plugin Contributor Pau Iglesias

    (@pauiglesias)

    The crawler works by internal scripts submitting the URLs status to the default ajax URL of WordPress,

    by default the admin-ajax.php returns 0 without any parameter, but in your case shows an error:

    http://schellinger-smb.de/wp-admin/admin-ajax.php

    It looks like an error response of malformed XML documents, can you check if you have a plugin to create sitemaps or something XML related?

    I have the same problem http://www.fayecossar.nl – using visual composer as well – is there a fix – as plugin is exactly what I want. thx

    Plugin Contributor Pau Iglesias

    (@pauiglesias)

    Hi fayebl,

    I’ve taken a look and externally everything seems ok, any chance to access to the error log of your server?

    You can contact me via the e-mail info (at) seedplugins.com

    Kind regards,
    Pau

    sent you a mail thx

    Plugin Contributor Pau Iglesias

    (@pauiglesias)

    Hi fayebl, I reply here also so that the answer is public,

    there is a conflict with the security plugin Wordfence,

    when the Wordfence Firewall is enabled, the crawler is frequently stopped or directly stops working.

    To run the crawler it is necessary to disable the Wordfence Firewall, and properly uninstall also the “Extended WordPress protection” to avoid conflicts with the crawler.

    For now turn off the firewall is the only solution, I will do some research on how to avoid this conflict for future releases.

    Regards,
    Pau

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Scan is crawling but not showing any results’ is closed to new replies.