Support » Plugin: BackWPup - WordPress Backup Plugin » Scaleway S3 Service

  • Resolved biggs31fr

    (@biggs31fr)


    Hello,
    I am trying to configure BackWPup with scaleway S3 Services. The configuration is ok, but when the backup is complete I have the error:
    API S3 Service: Part number must be an integer between 1 and 1000, inclusive

    I do not see any options to define the size of the parts and uncheck the box to allow the management of the parts do not want to uncheck.

    I managed to get the backup to work, but without taking the images and videos for a 400MB backup. My test site is only 5GB while my real site is 30GB.

    How to correct this problem?

    Thanks.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support duongcuong96

    (@duongcuong96)

    @biggs31fr
    hmm you can just exclude folders from being backed up in your job -> Files tab -> tick on these folders.

    just 5GB file size is a small number that should not have any issue, could you give me a hint on how to reproduce it?

    Thank you!

    Thread Starter biggs31fr

    (@biggs31fr)

    Hello,

    So I did some other tests, if my backup is less than 5GB, it works, but if it is more than 5GB, I get the error message.

    Which is “normal” because I checked with Scaleway and now it is no longer possible to put files over 5GB without cutting them (on your side or when sending).

    Can you therefore add a parameter to either make .tar files of 5GB each max, or use the Scaleway parameters to send the files in multiparts :

    https://www.scaleway.com/en/docs/storage/object/api-cli/multipart-uploads

    Thanks

    Plugin Support duongcuong96

    (@duongcuong96)

    Hi @biggs31fr
    hmm, could you try to configure the Scaleway in the To S3 Server URL section like this: https://prnt.sc/1uwrj3t
    Thank you
    Make sure the Multipart option is checked(it’s already checked by default)
    After that, run the job again. Thank you

    Thread Starter biggs31fr

    (@biggs31fr)

    Hello,
    I created a new task with the same settings as the first task :
    https://prnt.sc/1ux3t9j
    Always the same problem, if the backup is more than 5 GB, it does not work, if the backup is less than 5 GB, it works.

    On the other hand, at the time of the error on a 5GB backup, I saw in the bucket settings that there were 1001 parts while the maximum number is 1000 parts :
    https://prnt.sc/1ux479e

    And in the backup of less than 5GB, there are only 935 parts :
    https://prnt.sc/1ux586i

    Maybe the parts size is set to 5MB instead of 5GB, which explains the failures ?

    Thanks

    Plugin Support duongcuong96

    (@duongcuong96)

    Hello @biggs31fr
    Please help me try this modified path instead: https://www.dropbox.com/s/6olutuyy951s3hr/backwpup_s3_mod.zip?dl=0
    Thank you!

    Thread Starter biggs31fr

    (@biggs31fr)

    It’s working !

    But for the final site with 25GB, I change the size of the parts, now I see in the PHP files where to change the size.

    Maybe you can add a parameters to change easyly this size ?

    Thanks a lot !!

    Plugin Support duongcuong96

    (@duongcuong96)

    @biggs31fr
    hmm, I will suggest this to our devs ^^
    The issue now can consider closed ^^
    Thank you!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.