Support » Plugin: WP-SpamShield » Says not installed correctly – can you help?

  • Resolved fthomsen2

    (@fthomsen2)


    On the settings it says the plugin is not installed correctly. Can you help with this? I have been trying many spam filter plugins and hav not had muhc good luck so far. I read good things here so I’m hoping to get yors working. If not it will be just like all teh others. Thank you.

    fred

    https://wordpress.org/plugins/wp-spamshield/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Red Sand Media Group

    (@redsand)

    Hi Fred,

    I’m sorry to hear about the issue you’re having but I’ll be happy to help.

    Have you had a chance to go through the FAQs and Troubleshooting Guide? These solve 99% of users’ issues.

    If working through those doesn’t fix it for you, we’ll need a bit more info from you on the specifics, and we’ll need to email back and forth, so please head over to the WP-SpamShield Support Form, and take a moment to fill out a support request. That will allow us to take care of this as quickly as possible for you (and anyone else who is experiencing the same issue).

    – Scott

    Hi Scott,

    Thank you for getting back qucikly.

    I had not gone through the guides yet but I did after you said to. I found a couple things. In points 9 and 16 it revealed problems. I got the javascript error on 9 and on 16 with the jscripts.php file I got this error: 403 Forbidden.

    I tried to change the file permissions but it is still having the 403. Is there something else I can do? Should I do the support request on your site?

    Thank you for helping.

    – Fred

    Plugin Contributor Red Sand Media Group

    (@redsand)

    Hey Fred,

    You’re welcome. 🙂

    Sometimes there are file permissions or ownership issues that can only be fixed by a system administrator (your web host).

    The plugin has something called Compatibility Mode that may be able to help.

    It modifies the plugin behavior slightly to make it more compatible, and this can be helpful when users are having certain types of issues, including this one. It does sacrifice a few features, but it will still stop spam just fine.

    For more info on Compatibility Mode: http://www.redsandmarketing.com/plugins/wp-spamshield/#wpss_compatibility_mode

    If you turn this on, it should take care of the issue. To turn it on, first make a backup of your wp-config.php file (in the directory your WordPress is installed in), then open it up and add this line before it says to stop editing:

    define( 'WPSS_COMPAT_MODE', TRUE );

    Just a word of warning…since this requires editing your wp-config.php file, only do this if you’re comfortable, as it’s the main config file for WordPress.

    Once you do this, post a test comment to see if things are working for you. (Be sure you are logged out.)

    Let me know if that helps. If it doesn’t fix things for you, or if you’re not comfortable with this, then go do the support request so we can look into things in depth. (We’ll need to help you debug your site.)

    – Scott

    That worked!

    I edited the wp-config file as you said. Test comment went through now. Also in my settings page it says installed correctly now. Good!

    Thank you. Now I will test the plugin, and see how it fares against spam.

    Thank you for your help.

    – fred

    Plugin Contributor Red Sand Media Group

    (@redsand)

    Hey Fred,

    Excellent. Glad to hear it fixed things for you.

    Compatibility Mode is handy to help you out in situations like this, but I would still try to work with your web host to figure out those file permissions issues as they may become a problem later on, with other plugins or just in general.

    You’re welcome! Let us know if you need help again.

    – Scott

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Says not installed correctly – can you help?’ is closed to new replies.