WordPress.org

Forums

Says No comments When there are comments (7 posts)

  1. tijja
    Member
    Posted 8 years ago #

    My comments are no longer showing up under the posts. It says No comments even when there are comments. This started yesterday as far as I can tell. I upgraded to the latest WP version (1.0 is what I had I think), I added Wp-Polls, and Autometa (which didn't work and i have since deactivated).

    Help?

  2. Chris_K
    Member
    Posted 8 years ago #

    Are you running an old version of Spam Karma2? If so, make sure you have the latest version.

  3. tijja
    Member
    Posted 8 years ago #

    No I have the latest version of SK, when I deactivate it makes no diffeence in the comments count either.

  4. SM
    Member
    Posted 8 years ago #

    I think I have the exact same problem. I'm at 2.0.7, and I'm using spam karma 2.2

    I think the problem started when I upgraded from 1.5.2 to 2.0.2, and has stayed with me through several upgrades.

    Attempts to resolve:

    Removed everything but default themes. (did not work)

    Backed up entire database, backed up entire directory structure, wiped installation files, and installed fresh 2.0.7 (with old database untouched), ran upgrade script (did not work either)

    My problem is exactly as described above, I have comments on posts, and I can click on the post to show the post and the comments, but in the overview, it says "no comments" regardless.

    Any ideas?

  5. SM
    Member
    Posted 8 years ago #

    I found the problem, it <i>was</i> SK2.

    I had Spam Karma 2.0 Final r2 installed. While it was activated, the database isn't updated properly, specifically wp_posts in the comment_count category.

    The fix seems to be to make sure that you are using Spam Karma version: 2.2 r3.

    once you have installed the new version, future comments will be OK, <b>but posts with old comments need to be fixed</b>. There are two ways I know of doing this.

    1) go into the database and do it by hand (yes, that's slow and you do need to know how to stumble around in mySQLadmin

    or

    2) go to every post that has the wrong comment count, and add a comment. When the new SK2 approves it, the total proper count will be corrected. You could then erase that comment, count should then decrement OK.

    yea, both of those options suck. Sorry, that's the best I can do. Oh and I really wish that Dr. Dave would splash this all over his home page. I have months of posts that I now need to fix by hand.

    threads that helped:
    http://wordpress.org/support/topic/76832
    http://wordpress.org/support/topic/75323

  6. M
    Member
    Posted 8 years ago #

    Ran into the same problem myself after the upgrade to 2.1. Was surprised to have to dig around so much to find an answer, it can't be an uncommon problem.

    So glad someone found the problem, and even gladder that we don't have tons of comments on our blog. Now to add/delete a comment on each post....

    The SK2 upgrade took mere seconds. I'd already upgraded all my plugins and missed doing SK2 somehow so I thought all my plugins were up to date and never would've poked around there for a solution.

    *found that all you have to do is click on a comment and click the edit button instead of adding and deleting a new comment

  7. stevecherry
    Member
    Posted 8 years ago #

    I just wanted to confirm here that SK2 upgrade was the issue for me too. My guess is the problem is a bit more widespread than I thought. Just download latest version of Spam Karma, then deactivate the old and insert the new file.

    Go Here to download latest SK2.

    Happy blogging,
    Steve Cherry
    http://www.dailyframe.com

Topic Closed

This topic has been closed to new replies.

About this Topic