• Resolved TheArtfulDodger

    (@theartfuldodger)


    I was reviewing a quiz I set up last year, and the questions have been duplicated (don’t know why). So I am editing them and removing the duplicated entries.
    I can save some questions, but after 2 or 3 it goes into save mode and sits (timed at 10 minutes +) and i have to repfresh the page and redo the same thing again.
    Internet is fine, other sites (WP and non-WP) are working fine.
    Possible bug?

    Version: 3.22.1

    Db Version: 3.22.1

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    @theartfuldodger,

    The database structure with relation to quizzes changed significantly at LifterLMS 3.16. You can review the changes in our database migration docs here: https://lifterlms.com/docs/lifterlms-database-updates/#3160

    Quiz questions were intentionally duplicated but they shouldn’t have caused duplicates within the same quiz.

    If you’re seeing the save function “lock up for 10+ minutes” we’re likely encountering a plugin conflict. Can you disable all non LifterLMS plugins on your site and see if that helps?

    Let me know if it does help,

    I disabled all of my plugins except for the LMS plugins. the saving changes still continues (at 3 minutes currently).
    Could it be updating the tables? because I created this quiz on a much earlier version of the LMS.
    Also, the update database message does not show. Do I have to create a cron job to run it, or can I go to the SQL and update the tables directly?

    Thanks,

    Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    @theartfuldodger,

    I disabled all of my plugins except for the LMS plugins. the saving changes still continues (at 3 minutes currently).

    Can you use your JS console to see if any errors are being reported during save attempts. Open your console by following step 3 here: https://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

    Then try to save something in the builder. Hopefully the console will show a red error message that can help us identify what’s going on here.

    Could it be updating the tables? because I created this quiz on a much earlier version of the LMS.

    According to the DB version that you posted above the migration has already run so no, it’s not updating tables still.

    Also, the update database message does not show. Do I have to create a cron job to run it, or can I go to the SQL and update the tables directly?

    Did it show previously? Once you’ve run it it doesn’t show again. And since you’re on the latest DB version it would make sense that it doesn’t show right now.

    I feel like I’ve seen your name in email support before, am I wrong? If you have access to email support open a new support ticket about this. We can login to your site and help identify what’s going on but we only do that for customers.

    Thnaks,

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Saving quiz questions’ is closed to new replies.