Support » Plugin: Top 10 - Popular posts plugin for WordPress » Saving options not possible

  • Resolved gerobe

    (@gerobe)


    Hi,

    with 2.5.3 I can‘t save any options. I‘m clicking the save-button, but nothing happens.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Ajay

    (@ajay)

    Could I please ask you to try another browser as I don’t see that issue across any of my sites that I’ve been testing.

    It could be a javascript error. Worthwhile checking this by viewing it in the developer tools in Chrome or Firefox.

    Thread Starter gerobe

    (@gerobe)

    Tested on Firefox 56.0.2 and latest version of Chrome. Saving does not work with both browsers.

    Plugin Author Ajay

    (@ajay)

    Can I please ask you to try two things.

    In both cases, please back up your site.

    First one is reset the settings and try saving again. If that doesn’t fix the problem. Deactivate and uninstall the plugin and then reinstall it.

    Make sure that “Delete counter data on uninstall” is unchecked. https://ps.w.org/top-10/assets/screenshot-1.png?rev=1770116

    Both steps made listed above but still remains same and doesn’t work.
    Also settings remain the same. So you have to fix this plugin…

    • This reply was modified 3 years, 7 months ago by S o f t f u l l y. Reason: forget some extra more details to add

    Fixed:

    Go to: Top 10 Settings / General

    SET – Default custom period range: Day(s) 1 OR any under 30 days and in Hour(s) 0 OR not more then 23 hours

    That’s all…

    I want to be removed from these notifications. I have unsubscribed but still getting them. It os very irritating.

    Softfully.Com,

    I had already had those same settings by choice. Unfortunately, your solution did not work.

    None of the options are saved. In addition, the plugin is still tracking me and displaying page views to my readers (which I don’t want).

    Plugin author, please resolve this issue as soon as possible.

    Regards

    locutus45

    What is your Default custom period range: Day(s) and in Hour(s) ??

    Day(s) 1
    Hours(s) 0

    Plugin Author Ajay

    (@ajay)

    @softfully,
    Thanks for confirming.

    @locutus45, have you tried the steps above?
    Can you post screenshots of your settings, please?

    When trying to save numbers that do not fit the requirements, the browser will prompt you. This might be hidden in another tab, so please check the other tabs as well. Please check the other tabs for this. Resetting the settings will bring back the old version of the settings for those who upgraded recently which might not be compliant.

    The settings with numbers are in General, Posts list, Thumbnail and Maintenance tabs

    • This reply was modified 3 years, 7 months ago by Ajay.

    Resetting the plugin settings did not solve the problem, nor did deactivating and reactivating. No place to include a pic here.

    Display number of views on:
    x Posts
    x Pages
    x Home page
    x Feeds
    x Category archives
    x Tag archives
    x Other archives

    I want ALL of these options UN-checked. Each time I save, all of them are checked again.

    I’ll try deleting and re-installing when I get a chance, probably Wednesday.

    locutus45

    Fresh install will do good job
    We fixed yesterday and works great for us. Also we removed all tables (2 tables) from database and after fresh install we restore that 2 tables in our database back.
    There is no issue in this plugin.

    Thanks and try to install fresh…

    Thread Starter gerobe

    (@gerobe)

    Thanks @softfully

    Changing the default custom period range to 1 day and 23 hours made saving of the options possible (my old value was 0 day and 24 hours).

    So everything is working now.

    @gerobe

    The big trouble was in 24 Hours because more then 23 hours will not work.

    Please close this topic as resolved…

    • This reply was modified 3 years, 6 months ago by S o f t f u l l y. Reason: Forget the name
    Thread Starter gerobe

    (@gerobe)

    Yes, but the update-routine should better check for this wrong settings in older versions and correct it.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Saving options not possible’ is closed to new replies.