Support » Developing with WordPress » saving files is breaking my admin

  • Resolved startribe


    Hey Community,

    I ran into a very strange issue with WordPress. When I edit a pluggin then upload it to the server, it breaks my admin pluggin page. I troubleshot a bit and found out that when I simply re-save a pluggin with out edits and upload it the same issue takes place. I documented the problem with pics below:

    1-before re-saving on local computer:

    2-after saving the file with out any updates and uploading:

    I also ran into the same problem when editing Pages. As soon as I edited or saved a WP Page and uploaded it, it breaks my Pages admin page.

    I tried re-installing wordpress admin and then doing a complete re-install of wordpress, and neither worked out as solution.

    I am working on a Diablo Valley Hosting dedicated server which is more or less Godaddy, i.e., a reseller. The dedicated server uses Simple Control Panel for admin functions. I am also working on a shared location that I tested with the same parameters, and I didn’t experience any problems.

    I am thinking that there must be a setting on my server which is causing documents I am saving locally to interact strange with WordPress, and this only appears to be files that interact with WP admin.

    I’m a bit clueless here, and any ideas, suggestions, or help would be greatly appreciated.


Viewing 4 replies - 1 through 4 (of 4 total)
  • I want to give this a bump… I am hoping someone will have an idea.


    Ok, here is an update.

    • When I fist download a plugin form the web and upload it to the dedicated server, there is no problem.
    • When I edit it or save it in either Text Edit or Dreamweaver and upload it, it breaks my WP Admin
    • If I edit or save a file in ForgEdit, i’m on a mac, then upload the file, there is no break

    And a couple of other interesting things.

    • On my shared serving account (this is where I did the initial developing and design) the files that are uploaded show permissions of 644, and the plugins on the shared server can be edited within WordPress
    • On my dedicated server the files are showing permissions of 664, and I can’t edit them within wordpress unless I set the permissions to 777 (ayeee!)

    That is the latest for now. I am committed to figuring out a solution here, and any ideas or suggestions would be greatly appreciated.


    No mystery here. Your mac editors put a different line break than expected – and that screws up the files… thet’s why you see all that text instead of the usual plugin page.

    You either edit the files with the editor(s) you already figured out they work – or set your other editors to use unix line breaks (or something like that; I am not a coder just remember a lot from the forum).

    You may want to do a search for “unix line breaks” and similar keywords.


    My goodness. That was it, wow, I am learning something new every day here. Again, thank you so much, you have been so helpful through out my project 🙂

    Do you have any idea on the permissions issue? That is something that is a bit strange to me, i.e., not being able to edit pluggin within WP.

    I will do a search on “Unix Line Breaks,” for I want to know what this is all about. I did not know what to search before, so I was shooting into space.

    Thanks again,

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘saving files is breaking my admin’ is closed to new replies.