Support » Plugin: Yet Another Related Posts Plugin (YARPP) » Saving Changes gives 403 forbidden error – any ideas

  • Resolved FatherTed



    I love this plugin but it is now giving me an issue and I cannot save any changes from the settings page, I get this error (only on this plugin, all others are working fine):

    403 Forbidden

    You don’t have permission to access /wp-admin/options-general.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Apache Server Port 80


    Seems quite a common error but cannot find a real answer anywhere – I have searched and found suggestions for mod_sec in .htaccess file but they have not worked for me. Also deleted and reinstalled the plugin, but still the same issue.

    Any ideas on the problem or how can I make changes to the settings without using the settings page.

    Many thanks in advance.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi,

    Well, I think I have solved my issue – so here is my solution for any one else who comes across this in the future.

    1. Disable and delete the yarpp plugin.
    2. go to phpmyadmin and go through the wp-options database, delete any line that has yarpp in the title
    3. Reinstall yarpp
    4. In my case, it all now works correctly

    Gosh, I’m really sorry to hear about this. I’m really glad you were able to resolve it. If you have any suspicions as to how this might have happened, I’d love to know for the future.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Saving Changes gives 403 forbidden error – any ideas’ is closed to new replies.