Support » Plugin: Client Portal - Private user pages and login » Saving a private page with Gutenberg

  • Hi Guys,

    I am running WP 5.2.4 and have:

    Client Portal = Version 1.0.7
    Profile Builder = Version 3.0.5

    I updated my WordPress configuration to use the Gutenberg editor for custom post types. So now when I visit a private page I can press the in-page ‘Edit’ link and up pops the Gutenberg editor, I can then make changes to the private page. However, as soon as the page is saved the following occurs:

    Under the users area, normally there is a link “Private Page” under the username, once the private page has been edited (with Gutenberg) that link disappears.

    Then if I try and login with this user that just had his private page changed it loads the page but does not perform the forwarding to the private page. It is almost like the page is disassociated from the user and does not exit, but I can still go to the URL and edit it that way, but the whole forward the user after login is broken.

    It does not behave like this when I use the classic editor.

    I can’t not use the Gutenberg editor because I wish to use another plugin that is only supported in Gutenberg editor.

    It seems there is a problem here, anyone else using the Gutenberg editor to edit their users private pages?

    Any help welcome,

    Thanks, Charlie.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    Hello Charlie,

    I need to reproduce this experience.

    How did you update your WordPress configuration to use the Gutenberg editor for custom post types?

    I think I remember seeing something similar here in the forums, but searching for Gutenberg yields no results.

    With the best of regards,
    Gabriel

    P.S. Something that it might be worth to try: go to Dash -> Settings -> Permalinks and don’t change anything but just click on the Save Changes button.

    Hi Gabriel,

    Thank you for responding so quickly 🙂

    I also searched for Gutenberg in the forum and it yielded no results but I did find the thread that you are probably thinking of (point 1):

    https://wordpress.org/support/topic/problems-with-client-portal/

    To enable the Gutenberg editor for Private Pages (and all other CPTs) I changed the $defaults = array( setting:

    show_in_rest’=> false, TO show_in_rest’=> true,

    in the file wp-includes/class-wp-post-type.php

    I will have a look at this permalinks suggestion you made, but I am not optimistic, but maybe, just maybe 🙂

    Charlie

    Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    Hello Charle,

    Thanks for finding the thread… I see now that the development team has been announced and an issue has been added.

    I am now bumping it’s priority on the development list, but still can’t promise anything about when it might be fixed.

    With the best of regards,
    Gabriel

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Saving a private page with Gutenberg’ is closed to new replies.