Support » Plugin: Facebook for WooCommerce » Save button not working on Product Sync

  • Resolved Janafor

    (@janafor)


    The save button doesn’t work on the sync tab, it’s really frustrating as I need to exclude some categories. Just just doesn’t do anything. I tried various browsers and all the same. Please help….

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Support crazywickedawesome

    (@crazywickedawesome)

    Hi!

    Thanks for reaching out!

    To clarify, when you say the save button isn’t working you mean you’re trying to change your sync settings, and when you click the button and leave the settings page, nothing has saved?

    Can you try deactivating the Facebook for WooCommerce plugin, then reactivating it, and trying to make changes?

    Let us know if that works!

    Thread Starter Janafor

    (@janafor)

    Thank you for your reply! Yes, that’s what I mean, if I change anything and then click save, it doesn’t do anything. I deactivated and reactivated the plugin and it didn’t help unfortunately. Seems like I am not the only one with this problem, I found more posts about the same thing (with no solution).

    • This reply was modified 9 months ago by Janafor.
    Thread Starter Janafor

    (@janafor)

    Actually, it works when I select a google category and with description choice. But not with excluding tags and categories.
    Comes up with this error in the console:

    underscore.min.js?ver=1.8.3:2 Uncaught TypeError: Cannot read property ‘replace’ of undefined
    at Function.v.template (underscore.min.js?ver=1.8.3:2)
    at wp-util.min.js?ver=5.6:2
    at i.render (backbone-modal.min.js?ver=4.9.1:1)
    at initialize (backbone-modal.min.js?ver=4.9.1:1)
    at i.h.View (backbone.min.js?ver=1.4.0:2)
    at new i (backbone.min.js?ver=1.4.0:2)
    at Object.success (facebook-for-woocommerce-settings-sync.min.js?ver=2.2.0:1)
    at c (jquery.min.js?ver=3.5.1:2)
    at Object.fireWith [as resolveWith] (jquery.min.js?ver=3.5.1:2)
    at l (jquery.min.js?ver=3.5.1:2)
    v.template @ underscore.min.js?ver=1.8.3:2
    (anonymous) @ wp-util.min.js?ver=5.6:2
    render @ backbone-modal.min.js?ver=4.9.1:1
    initialize @ backbone-modal.min.js?ver=4.9.1:1
    h.View @ backbone.min.js?ver=1.4.0:2
    i @ backbone.min.js?ver=1.4.0:2
    (anonymous) @ facebook-for-woocommerce-settings-sync.min.js?ver=2.2.0:1
    c @ jquery.min.js?ver=3.5.1:2
    fireWith @ jquery.min.js?ver=3.5.1:2
    l @ jquery.min.js?ver=3.5.1:2
    (anonymous) @ jquery.min.js?ver=3.5.1:2
    load (async)
    send @ jquery.min.js?ver=3.5.1:2
    ajax @ jquery.min.js?ver=3.5.1:2
    s.ajax.s.ajax @ jquery-migrate.min.js?ver=3.3.2:2
    S.<computed> @ jquery.min.js?ver=3.5.1:2
    (anonymous) @ facebook-for-woocommerce-settings-sync.min.js?ver=2.2.0:1
    dispatch @ jquery.min.js?ver=3.5.1:2
    v.handle @ jquery.min.js?ver=3.5.1:2

    Plugin Support Doug – a11n

    (@dougaitken)

    Automattic Happiness Engineer

    Hi @janafor

    Thanks for the additional details.

    I’m afraid that currently, this is a known bug in the extension – https://github.com/facebookincubator/facebook-for-woocommerce/issues/1725

    Thanks,

    Plugin Support AJ a11n

    (@amandasjackson)

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

    Curiously, the Save button works again when you add at least one set of products in the new “FB Product Sets” section of plugin.

    Thread Starter Janafor

    (@janafor)

    Just did that and it still doesn’t work for me… unbelievable… how long has this been broken now???

    Thread Starter Janafor

    (@janafor)

    I really WISH this was resolved. But it isn’t.

    I have WP 5.6.1, WC 4.9.2, PHP 7.3 and the latest version of this plugin (2.3.0).

    Thread Starter Janafor

    (@janafor)

    I have updated everything before I tried …

    time to fix this as still unresolved…. can’t use the sync feature at all as I need to exclude specific categories

    Thread Starter Janafor

    (@janafor)

    Yup. I saw there was a new update so I was hoping that would be fixed no. And NOPE. One would think something this important would be a priority…

    Since the first post is marked as resolved has anyone got a solution?

    Regards

    Thread Starter Janafor

    (@janafor)

    I don’t really know why it’s marked as resolved as the problem is still there. Seems like they just don’t care the plugin is broken.

    Plugin Support Cara – a11n

    (@dcka)

    Hi, @janafor!

    I don’t really know why it’s marked as resolved as the problem is still there. Seems like they just don’t care the plugin is broken.

    Sorry about that! Topics are marked as resolved if we haven’t heard back from the thread-starter in at least a week. I have since changed the status again to “not resolved.”

    As for the issue you’re experiencing with excluding categories, it is still open, but if you’ll check the report for it on GitHub, we are expecting a fix for it in the next release, 2.4.0.

    We do appreciate your continued patience with this!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Save button not working on Product Sync’ is closed to new replies.