Support » Fixing WordPress » save button gives 404 post.php not found

  • Hi
    I have installed wordpress with the chenpress editor and it all works great until I click the save or publish button which gives a file not found error. I have my installation in a folder called ‘blog’ but the button is calling the file /wordpress/wp-admin/post.php whereas the correct path is /blog/wp-admin/post.php.
    All other links appear to work fine so where can I change the button behaviour.
    Any help much appreciated.

    mouli

Viewing 5 replies - 1 through 5 (of 5 total)
  • Is the “WordPress address” correct under Options > General?

    Hi filosofo,
    Sorry for the slow response. Yes I’ve checked the wordpress address and it shows correctly as http://www.mysite.com/blog.
    From the code it looks like its not getting the right urk from get_settings() function but I cant find where that function lives or where it gets its parameters from.

    It’s possible that a plugin could be changing it. Have you tried deactivating your plugins?

    I’m using chenpress and possibly the problem started then…. well spotted. I tried disabling chenpress but the problem remained so maybe I need to change the url for the blog back to /wordpress/ instead of /blog/ then at least it will be the default and chen press may recognize it.

    Yea, it worked by turning off the damn mod_security.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘save button gives 404 post.php not found’ is closed to new replies.