Support » Fixing WordPress » “Save and Continue Editing” causes a delay, then a blank screen

  • I’m writing posts in WP and when I click to “Save and Continue Editing”, I get a long delay, then a blank browser window. The Dashboard doesn’t come up. If I click my browser’s back button it will take me back to the Dashboard, but the new content is gone. I’m using Firefox (latest version) and I just upgraded to WP 2.0.5 to see if perhaps this was a bug that was fixed in the new version. The same situation is happening.

    I’m wondering if anyone else is having this problem, or can offer advice. This is happening 80% of the time, and it’s driving me crazy. I have to compose outside of WP to insure that my work doesn’t get lost, then I take my chances as I post in WP whether it will show up or not.

Viewing 15 replies - 1 through 15 (of 25 total)
  • I am having a similar problem, except for me it is 100% of the time since upgrading to 2.0.5. and it is happening for me in FF2, IE6, and Opera 9. In my case, clicking Publish, Save and Continue Editing, or just Save will cause the “post.php” to appear as if it has stalled. Then the page goes blank. If I log back in, however, what i posted has been saved and/or published. As such, it seems to me the problem is in the refreshing the existing page. But I cannot figure out why and cannot find a solution anywhere for it so far.

    So far, I have tried:

    1. disabling plugins
    2. re-uploading the wp-admin/post.php file (figuring it might be corrupted)
    3. increased my server’s PHP RAM from 12mb to 16mb
    4. deleted cookies and javascript from my browser’s cache
    5. re-uploaded all of 2.0.05 to see if that would help
    6. removed all links to pingomatic and other update services
    7. Installing the “WP-Tuneup” Plugin to see if that would help. It didn’t.

    So far, nothing has corrected this for me.

    The server is a dedicated dual xeon with 2 GB of RAM, and the only sites on it are my own which are low traffic.

    I’m stumped, that’s for certain. I too would be interested in anything else I could try to resolve this issue.

    Well, Rongo,

    I’m glad to see someone else is having the same problem, so I know it’s not just me. Though you’re as mystified as I am about this one.

    My blog has been working very well for months until this just started to happen in the last few weeks.

    Just to add to the list of browsers, this also happened on my Mac using Safari 2.0.

    Rongo,

    I would agree with your statement about the problem,

    As such, it seems to me the problem is in the refreshing the existing page.

    That seems to be the problem. I note that the posts do go up, but the screen is not refreshed. I would like to continue editing or just preview the post below.

    David, I’ve continued to search for a resolution to this issue, but still none found.

    Short of downgrading to 2.0.4 (where everything worked flawlessly), I’m not sure what else to suggest. Downgrading is not a reasonable option either, however, since it contained security flaws that have been patched in 2.0.5.

    I don’t see many other people posting publicly about this, so it’s likely not a widespread issue that you and I are experiencing. Thus, unless many more people start experiencing the same thing, or until the WP crew can find time to duplicate this same issue, my guess is we’re SOL.

    this has happened to me too but not when clicking on save and preview.. it happened everytime i tried to save a post either to preview or just publish

    I would not get a white screen though, i would get the static.wordpress.org page saying there was a database connection problem

    I deleted teh entire blog and set it up from scratch again and it works fine.. i am also using 2.0.5

    Danfef: Thanks for the tip. But honestly, I am hoping for a more practical solution/fix from the WP team. Starting from scratch is, for me, a very last resort and one I am very reluctant to do.

    At the very least, the fact that more than one person is experiencing this after upgrading to 2.0.5 is an indication to me that an oversight or incompatibility exists in the upgrade process from 2.0.4 to 2.0.5.

    HandySolo: Thanks. While I cannot speak for anyone else in this thread, I have tried that plugin a few days ago. It unfortunately did not correct the issue for me.

    I’m unsure what else to do. It’s not a widespread issue, obviously, as only a handful of people are reporting the problem. But it is indeed frustrating nonetheless trying to resolve the issue.

    Long shot: Options -> Writing, do have any/many entries in “Update Services”?

    HandySolo: one of the things I tried (see my earlier post with bulleted entries), was to try removing all the update services. I think I have tried just about everything.

    It never helped any, but honestly, I never expected it to since the problem for me is that it is “hanging” even when using the “Save and Continue Editing” feature. Everything is saved, but the problem is that the page never refreshes. it stalls between the pushing of the button and the refreshing of the page.

    Thanks though for the suggestion(s). Much appreciated.

    i am experiencing the exact same problem: wordpress 2.0.5 is working flawlessly except for steady timeouts on publishing (and saving previously published) pages. as soon as i hit the publish button the actual article is placed on the blog and listed on the Manage page, but post.php doesn’t refresh or redirect at all.

    this goes for each post, with or without images or url’s in it. all external checks, pings and whatnot are disabled.

    Has anyone from the WP team been able to duplicate this error, or have any further suggestions?

    It’s been a couple of weeks since upgrading to 2.0.5 from what *was* a perfectly working 2.0.4. No matter what I have tried, there is a problem in the post.php refreshing after *any* use. (Save and Continue, Save, and Publish).

    Is the *only* suggestion left to simply wipe out the entire site and start over?

    Just an update on this… my problem is resolved.

    It was the log file created by the plugin, Google Sitemap Generator for WordPress 3.0b3 — note, I am using the BETA version of the plugin. Once I cleared that log (which was very, very long), everything is working perfectly again.

    As it turns out, it was not a problem with WordPress itself, for me anyway. I was mistaken.

    Thanks for the followup, Rongo.

    Same here, with Snap Preview Anywhere plugin.

    If activated, blank page after “save” or “save and continue editing”; if deactivated, everything ok.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘“Save and Continue Editing” causes a delay, then a blank screen’ is closed to new replies.