WordPress.org

Forums

Satoshi theme options - do not load (4 posts)

  1. aerozg
    Member
    Posted 4 years ago #

    I have installed the WAMPServer on my local PC, running Windows XP SP3.
    Created the database using phpMyAdmin, created a new user, edited the wp-config.php etc.. and installed WordPress.

    I have downloaded the fancy Satoshi theme from VooshThemes (http://www.vooshthemes.com/gallery/satoshi/) but cannot access the Theme options menu. The Theme options menu is used to cinfigure some parts of the theme. I'm rather new to PHP and i tried to fiddle with the theme's "functions.php" file but no luck so far.

    Anyone had the same issues with this?

    Thanks!

  2. khabaroff
    Member
    Posted 4 years ago #

    Got same problem.

  3. khabaroff
    Member
    Posted 4 years ago #

    On linux hosting works good, not on windows localhost.

  4. henriksjodahl
    Member
    Posted 4 years ago #

    As khabaroff say this error seem to only appear on Windows solutions.

    How to fix it:
    You'll have to edit the functions.php file in the Satoshi Theme (located in wp-content\themes\satoshi)

    Open functions.php and scroll down to line 75 where you find the following line:
    add_theme_page( "Satoshi Theme Options", "Theme Options", 8, __FILE__, 'theme_options_admin');

    You will have to change the line for:
    add_theme_page( "Satoshi Theme Options", "Theme Options", 8, 'satoshi-theme-options', 'theme_options_admin');

    Now everything should work great on both Windows and Linux solutions

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.