Support » Plugin: WP Photo Album Plus » Sanitize filenames

  • Resolved maddaze

    (@maddaze)


    Jacob,

    Is it possible to have an option in sanitizing filenames that contain accented letters (àéèïî…) to keep the letter without the accent? My photos are of churches in France and the name of the town or church becomes unsearchable after the accented letters have been removed (“La Brède” => “La Brde”, “Château Léognan – chapelle” => “Chteau Lognan – chapelle”, “Eglise réformée” => “Eglise rforme”,…).

    Thanks for considering this.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Jacob N. Breetvelt

    (@opajaap)

    You can now untick Table IX-D19: Sanitize files to keep accented chars.

    maddaze

    (@maddaze)

    Sorry for taking so long to get back to you. I’d expected an email when you replied, but I didn’t get one.

    I noticed when the option was added to Table IX. However, WP’s Media Library is not happy with accented letters. So, I currently use the plugin “BEA – Sanitize Filename” on one site while I develop another organized around WP Photo Album Plus. It works wonderfully in suppressing the accents and leaving the letters. Is this possible in WP Photo Album Plus?

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    If you untick Table IX-D19 you can search them with the accents.
    I will add another option to just strip the accents as described here:
    https://developer.wordpress.org/reference/functions/remove_accents/

    The option you propose is exactly what I’m looking for.

    Thank you, thank you, thank you!

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Fixed 7.1.09 Table IX-D20

    Thank you for implmenting this so quickly!

    However, I think there may be a bug. I did an import with both IX-19 and IX-20 checked and the accents letters in the filenames were still suppressed. “La Brède” became “La Brde”, which is exactly what happened previously. I had expected the removal of accents to happen before the sanitizing occurred.

    A couple of typos: on line IX-20, the prompt reads “…during import/uploas” rather than ” …during import/upload” and the symbol for help is ! rather than ?.

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    It works correctly on my testsite.

    Importing is always uncertain to me because of the fact that i do not know what the servers filesystem does with ‘illegal’ characters. This is server os dependant.

    Try:
    Untick IX-D19: Sanitize files (is not so dangerous as the helptext says)
    Tick IX-D20: Remove accents

    If no success: use Upload page instead of Import page

    Typo ‘uploas’ will be corrected.

    The help link is ? when the setting is at the default, ! when not. So you can quickly see if it is set at the default. I thought that was usefull….

    Thanks again for the quick response.

    I thought sanitize was useful for removing quotation marks and such. In any case I’ll test on my site (hosted by o2switch) and get back to you with what I discover.

    You realize this is all the fault of the Americans! When they popularized computers and created the Internet, they used their simple character set. And programmers have been tryng to cope with more extended character sets ever since.

    Harvey, an American in France

    I’m back to report that leaving IX-D19 unchecked and IX-D20 checked is the right combination for my Web site.

    After a test import I thought the accents had come through, until I realized it was the title with the accents — they had been stripped from the slug as requested.

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Thanx for coming back to me. I will change the defaults likewise, and remove the warning in the helptext

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.