Support » Fixing WordPress » Sanitize and resave all permalinks

  • Resolved Jack

    (@moxie)


    An older site has been moved by the provider from an older server type to a new one, resulting in permalinks like /This-Person’s-name-(12.03.04) giving a 404. So all characters except letters and numbers should be removed from the permalink. It would be nice if I could also remove -(*) at the end of all those older posts, but if that is too difficult it would be okay to get permalinks like /this-persons-name-120304

    The site had more than 1000 posts, so doing it manually is too much work. I hope someone has a suggestion how to solve this. Thanks!

    • This topic was modified 6 months, 2 weeks ago by Jack.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi Jack @moxie,

    Thought I’d give this a shot as no one else has replied yet. I presume you have tried the old classic of going into the Permalink settings in your WP Admin dashboard and just saving it? That regenerates the links and can sometimes fix issues like this.

    Kind Regards,
    Tim

    Thread Starter Jack

    (@moxie)

    Hi Tim, thanks for trying 🙂

    Yes, I allready saved the permalinks as default (?p=1234) and after that resaving it permalink with post title, but that didn’t help.

    Hi Jack,

    Have you checked your .htaccess file is correct? The defaults can be found here.

    Kind Regards,
    Tim

    Thread Starter Jack

    (@moxie)

    Htaccess was fine. I think I got it solved now but using this plugin:
    https://nl.wordpress.org/plugins/rebuild-permalinks/

    But something went wrong at some point, because I suddenly have lots of post twice in my database/WP installation. Once with and once without categories and tags :(. That will take me a few hours to correct, but luckily links are working again.

    Tim

    (@tneville)

    Hi @moxie,

    Glad to hear you’re sorted! Thanks for the feedback.

    Kind Regards,
    Tim

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Sanitize and resave all permalinks’ is closed to new replies.