WordPress.org

Support

Support » Plugins and Hacks » Polylang » [Resolved] Same post in different URLs

[Resolved] Same post in different URLs

  • There is post with URL site.com/en/post1.html. (English is not default language).
    URL Site.com/post1.html returns the same post in English, but with taxonomy in default language. Canonical URL of this site.com/post1.html is still site.com/en/post1.html.

    http://wordpress.org/extend/plugins/polylang/

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Chouby

    @chouby

    I reproduce the bug if I manually type “site.com/post1.html” in the browser address bar. But is there somewhere a link that leads to “site.com/post1.html”?

    I have found this bug when manually typed Url in adress bar too. Any other links I didn’t found.

    Plugin Author Chouby

    @chouby

    The new development version should now solve this.
    http://downloads.wordpress.org/plugin/polylang.zip

    It works as redirection from site.com/post1.html to site.com/en/post1.html?
    Most of post works good, but in some cases it returns cycle redirection when I try to go to site.com/en/post1.html.
    This is an example http://pblog777.16mb.com/en/post-3-2.html

    Plugin Author Chouby

    @chouby

    Is there something special with this post compared to the other which work

    Plugin Author Chouby

    @chouby

    I added a protection against chained redirections similar to what is done by WordPress in such case.
    http://downloads.wordpress.org/plugin/polylang.zip

    In 0.9.5 it works :!)

    Plugin Author Chouby

    @chouby

    Yes but it introduced a new bug 🙁

    “/category/name/page/2” redirects me (301 – permanentely) back to “/category/name/”

    I totally reworked this in the current development version (0.9.5.5)
    http://downloads.wordpress.org/plugin/polylang.zip

    I have tested 0.9.5.5.
    It works 🙂

    Plugin Author Chouby

    @chouby

    Thank you for your test!

    🙂

    It is an interesting thing. For post in default language (for default language prefix not used) site.com/post1.html URL address site.com/en/post1.html – still returns this issue. For post in non-default language (with prefix) such as site.com/en/post2.html and URL address site.com/post2.html redirection works correctly.
    Canonical URLs in all cases – are correct.
    Version 0.9.7. tested.

    Plugin Author Chouby

    @chouby

    Sorry. I am not sure I understand what is exactly the issue.

    With permalink : /%postname%.html
    If en is the default language, and I enter site.com/en/post1.html, it returns 404

    With permalink : /%postname%
    If en is the default language, and I enter site.com/en/post1, it is redirected to site.com/post1

    Is it this issue you are referring to?

    Permalink : /%postname%.html
    Default language – not English
    Prefix used only for non-default languages.
    site.com/post1.html – post in default language
    site.com/en/post1.html – still returns post in default language but with English taxonomy.

    site.com/en/post2.html – post in non-default language (English).
    site.com/post2.html redirect to site.com/en/post2.html – it is right redirection.
    Hm… May be it is impossible to do right redirection in all cases…

    Plugin Author Chouby

    @chouby

    Now I understand. I did not cover this case. Could you try with the new development version (0.9.8.1)?
    http://downloads.wordpress.org/plugin/polylang.zip

    And yes you are right, I will probably not cover all cases.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] Same post in different URLs’ is closed to new replies.
Skip to toolbar