Support » Plugin: Brilliant Web-to-Lead for Salesforce » Salesforce Integration Only Works When Option Checked

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Nick Ciske

    (@nickciske)

    Ummmm… that’s interesting.

    That should not be happening … so I can’t tell you how to fix it without some info:

    1. Which version of the plugin are you running?
    2. Can I see a form with this issue (e.g. a link to a live form)?
    3. Does changing to a bundled theme fix the issue? (e.g. twenty twelve)?
    4. Does deactivating all other plugins fix the issue? If so, please reactivate one by one until the issue reappears to find the conflicting plugin.

    thanks for responding…

    the client asked if we can just set it to checkmark itself automatically.

    can i do that by editing these codes somewhere? we need to launch soon so i think this would be more time efficient than troubleshooting.

    $content = $this->checkbox(‘showccuser’,__(‘Allow user to request a copy of their submission’, ‘salesforce’) );

    //send me a copy
    if( $options[‘showccuser’] ){
    $label = $options[‘ccusermsg’];
    if( empty($label) ) $label = __(‘Send me a copy’,’salesforce’);
    $content .= “\t\n\t”.'<p><label class=”w2llabel checkbox”><input type=”checkbox” name=”w2lcc” class=”w2linput checkbox” value=”1″/> ‘.esc_html($label).”</label><p>\n”;
    }

    Plugin Author Nick Ciske

    (@nickciske)

    //send me a copy
    if( $options['showccuser'] ){
    $label = $options['ccusermsg'];
    if( empty($label) ) $label = __('Send me a copy','salesforce');
    $content .= "\t\n\t".'<p><label class="w2llabel checkbox"><input type="checkbox" name="w2lcc" class="w2linput checkbox" value="1" checked="checked"/> '.esc_html($label)."</label><p>\n";
    }

    checked=”checked” is the key bit to add.

    The user can still uncheck it so it’s not a perfect solution.

    No worries, I plan to just make it transparent so they can’t see it. Do you think that would work?

    No worries, I plan to just make it transparent so they can’t see it. Do you think that would work?

    Plugin Author Nick Ciske

    (@nickciske)

    Display: none may cause it not to be submitted (not sure, you’d need to test).

    I tried it and it did not work..

    However, what DID WORK is removing clear: both;

    Yaay!

    Plugin Author Nick Ciske

    (@nickciske)

    I don’t see how that’d work, but I’m glad it did.

    Whenever you want to share some info about your install, I’d like to see if this is a real bug, plugin conflict, or something else.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Salesforce Integration Only Works When Option Checked’ is closed to new replies.