WordPress.org

Support

Support » Plugins and Hacks » WooCommerce SagePay Direct Payment Gateway » [Resolved] Sagepay direct (onsite) not completing order in Woocommerce

[Resolved] Sagepay direct (onsite) not completing order in Woocommerce

  • jim

    @jimcallender

    Hi there

    I am using sagepay direct in woocommerce for payments on the site.

    The money is being captured. Sagepay mode is set to live.

    However, the order status of the orders is not being marked as completed.

    Also related to this – the order emails are not being sent out to customer.

    I do not need pci compliance?

    Can you please advise what I should be checking to make sure this is working correctly?

    Thanks

    http://wordpress.org/extend/plugins/sagepay-direct-for-woocommerce-payment-gateway/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author swicks

    @swicks

    Hi

    Does everything work in test mode?

    I would expect once the payment was taken the order status would show ‘processing’ and when you have sent out the goods you would set the status to ‘complete’.

    In the custom fields on the admin order page should show the status of your transactions with SagePay and also in the SagePAy Direct table.

    regards

    Steve

    jim

    @jimcallender

    Thanks for the reply.

    I will check the custom fields.

    I didn’t realise this is manual. Ie switching order from processing to complete.

    I have also noticed there is no ssl in place.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Sagepay direct (onsite) not completing order in Woocommerce’ is closed to new replies.
Skip to toolbar