Support » Fixing WordPress » Safari Issues & WordPress

  • Resolved oseary

    (@oseary)



    I’ve googled the heck outta my issue and haven’t found anyone else with the same issue… I’m a Mac user who has a WordPress 2.2 site (pesosforpenguins.com) and I recently decided to test out Safari 3. It’s sposed to be faster and blah blah so I gave it a go.

    I can see my site fine, login to it without issue, and make new posts. However, the line breaks (pressing enter) never seem to “stick” when pressing “publish.” Am I missing something in either Safari or my WP configuration?

    Everything works great in Fireyferret and IE (on a PC), just not in Safari.

    Anyone else had this issue, or can anyone lead any guidance? An example of my issue can be seen at this post (as it’s all one massive paragraph) :

    http://www.pesosforpenguins.com/2007/06/12/safari-for-mac-beta/

    Thanks!!

Viewing 11 replies - 31 through 41 (of 41 total)
  • I have those exact two lines (4025 & 4026) in my file… Am I supposed to be changing something?

    Splendid! I found the lines a couple of lines later in the file (I’m running 2.3.2), but I just commented them out and now the problem’s gone. Thanks!

    PS: @oseary, yes, like meetnet21 says, just remove them or disable them. I commented them out, but just plain deleting them will work.

    I can ALSO verify that the “hack” works!! YESSSS! Thaaank you @meetnet21.

    We can consider this FINALLY closed. But will it be fixed in the next version? 🙂

    This seems to be working for me as well.

    I am curious what exactly these lines of code do, or in other words what functionality are we disabling by commenting these out?

    Yes indeed that did the trick. Very pleased. Thank you!!!

    If someone does actually figure out what exactly was disabled by this action it would be very nice to know.

    Anywho. Thank you

    Hi,

    I’m still seeing the same problem even after removing the 2 lines of code from the tiny_mce.js file as suggested above.

    I’m using WordPress 2.3.2 and Safari 3.04

    Any other ideas? This is driving me crazy!

    Many thanks, meetnet21. It worked fine for me too.

    FYI, in WordPress 2.3.2 those statements are on lines 3950 and 3951. And for those who may not know, the file is found at /wp-includes/js/tinymce/tiny_mce.js.

    I hate modifying core files, but it sure beats having editors using Safari messing up every post they touch if I forget to turn off the visual editor for them.

    Okay

    Am I crazy??? I’ve been having the same problems, then magically it was working all this week until today. Back to no paragraph breaks. Anyone else notice this strange occurrence? I didn’t do anything different and it was working, now today it’s not.

    Grrrrr

    Also, I am a newbie – I just use wordpress.com to post and am not running wordpress on my computer, so I cannot edit these files…

    The hack worked for me, too, but now the shortcut tags menu is gone and I no longer have the ability to format text or the page. So, I decided to put the deleted 2 lines of code back into the page. But the missing menu still does not return, even when I have “Visual” turned on my profile.

    I am getting so aggravated with WP right now. I tried FCKedit in lieu of TinyMCE, but it has a big problem with uploading images and is just as frustrating when it comes to being able to manage images.

    I’d rather go back to TinyMCE with the hack but I do need the menu bars, because this for the guess bloggers who will be inserting images.

    If someone could help me with this, I would be really greatful.

    Thanks.

    Changing the code didn’t work for me either, but I began using Fluid as a workaround. It basically creates an app for a single website and works fine with the editor. So I don’t quite feel like I’m abandoning Safari so much as just launching a dedicated admin app… I wrote briefly about it this morning here. This should also work for anyone on wordpress.com, just set the Fluid destination to your admin page.

    If by “bug” we mean that, when using safari and WP 2.3.3, that WP strips all paragraph returns out of either the “visual” or “code” panels when posting, then yes, I can replicate the problem. Commenting out the code, as suggested above, does not fix the problem.

    To add insult to injury, if I copy text from MS Word to Safari, Safari will faithfully place all RTF formatting into the post field. Thereby killing the theme with arbitrary text formatting code. I file it under “thanks for nothing.”

    I don’t have either problem when using camino. I’ve advise my client to switch to camino but safari support would be nice, of course.

Viewing 11 replies - 31 through 41 (of 41 total)
  • The topic ‘Safari Issues & WordPress’ is closed to new replies.