WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Safari Issues & WordPress

[Resolved] Safari Issues & WordPress

  • I’ve googled the heck outta my issue and haven’t found anyone else with the same issue… I’m a Mac user who has a WordPress 2.2 site (pesosforpenguins.com) and I recently decided to test out Safari 3. It’s sposed to be faster and blah blah so I gave it a go.

    I can see my site fine, login to it without issue, and make new posts. However, the line breaks (pressing enter) never seem to “stick” when pressing “publish.” Am I missing something in either Safari or my WP configuration?

    Everything works great in Fireyferret and IE (on a PC), just not in Safari.

    Anyone else had this issue, or can anyone lead any guidance? An example of my issue can be seen at this post (as it’s all one massive paragraph) :

    http://www.pesosforpenguins.com/2007/06/12/safari-for-mac-beta/

    Thanks!!

Viewing 15 replies - 16 through 30 (of 41 total)
  • Yes – this is a REAL problem … talk about incompatibility !!!

    This one is really surprising …

    Any movement on this subject?

    I just got back from a vacation and noticed the same thing. I, too, thought I was crazy. I got the Safari 3 in a Mac software upgrade. It’s very annoying and no one seems to know what to do to fix it.

    This sucks!

    BUMP for HELP

    Hey Turkey… We’ve been waiting on support for a very long time. It isn’t something that you can tweak to fix (as we understand it)… It’s a flaw with Safari.

    If you look up above, I bumped it way back when I started this thread. There is no fix–yet.

    Makes me glad I don’t use the dang editor. But, I see progress on the horizon:

    http://tinymce.moxiecode.com/punbb/viewtopic.php?id=9265

    I doubt that it will solve our issue… Nothing mentioned in the release notes about Safari and/or line/paragraph breaks.

    They “say” they support Safari 3, due to it having a portion of the “market share,” however I’ve found it only truly works without issue on IE & Fireyferret.

    We’ll see if it fixes it, but I’m not holding my breath.

    There are some ways to supposedly fixing it, however fixing the paragraph/line break glitch causes other glitches.

    I simply want it to work so that I can use Safari 100% of the time. I love its speed, but hate that I would have to switch over to FF just to post… I prefer the all-in-one solution.

    LOL πŸ™‚ So this is the problem? We were trying to figure out why we were (are) having SO MANY issues with the WYSIWYG editor in wordpress. We even wrote our post out in a HTML editor to fix all of the problems but as soon as we pasted it back in and clicked ‘Save’ we were right back at square one πŸ™ It was getting SO frustrating that we were actually thinking of switching away from wordpress to another type of blog software. Glad we found this thread. I am PRAYING that wordpress fixes this problem soon! I’m not sold that it’s a Safari issue because no other WYSIWYG editor is having any problems on Safari 3.0, including the one that we use to manage all of our vB forums. I guess we could use FF temporarily, but if this issue continues much longer it’s going to be bye-bye wordpress, as it took us 40 minutes to post a simple 5 minute page just to get it to look right. Fingers crossed that something gets fixed soon!

    Although not an answer- a workaround.

    Find your ‘tiny_mce.js” file, it is in ‘wp-includes/js/tinymce/tiny_mce.js’

    Line 7572, you need to change:

    // if ((tinyMCE.isGecko || tinyMCE.isOpera || tinyMCE.isSafari) && tinyMCE.settings.force_p_newlines && e.keyCode == 13 && !e.shiftKey) {

    to:

    if ((tinyMCE.isGecko || tinyMCE.isOpera) && tinyMCE.settings.force_p_newlines && e.keyCode == 13 && !e.shiftKey) {

    (Edited from: http://ijneb.com/archives/2007/10/13/safari-3-wordpress-2-tinymce-and-paragraphs/)

    @webdressing… It actually seems to be more of a TinyMCE and Safari issue. TinyMCE is coded into WP as the WYSIWYG editor (I think). It’s a pain, I know! πŸ™‚

    @wilcosworld… Thanks for that… I have no line 7572 in my tiny_mce.js file. Thanks for it though.

    Yes, the problem emerged with the latest Safari update (3.0.4).

    Visual and Code editor does not function correctly, and does not retain line break or paragraph tags. A real pain in the bum.

    Firefox seems to work fine, so I’ve switched to that for editing WordPress, and now ignore software updates from Apple for at least a month.

    @clatterbox, it seems to me that it has been going on since Safari 3 was even in the Beta stage. At least, that’s how I’ve experienced it with my Mac.

    Today I tried it after the latest security updates were released to Safari (and other apps), but was blown back by what occurred. Line breaks etc. function 100% fine in the comments section, but not inside of the general post writer.

    I am assuming this is because the comment box (unless otherwise modified to do so) doesn’t utilize the TinyMCE coding, that is present in the post creator.

    Hopefully, an update is near, but I do not hold my breath.

    This appears to be caused by browser specific hacks for Safari. If you have the Safari debug menu enabled you can change your User Agent to Firefox to correct the problem. So for the record it was something Apple fixed in Safari that broke a hack. WordPress needs to catch up.

    I can confirm that this does work… But when we change our “user agent” to FF, do we still get the native speed of Safari?

    I have found the bug, to solve it just remove or disable the following lines in file tiny_mce.js,it will work on safari 3, but i’m not sure if it can work on Safari 2.

    4025: if (tinyMCE.isSafari && this.formElement)
    4026: this.formElement.innerText = htm;

Viewing 15 replies - 16 through 30 (of 41 total)
  • The topic ‘[Resolved] Safari Issues & WordPress’ is closed to new replies.